Closed Bug 501757 Opened 10 years ago Closed 10 years ago

Links are not showing when above a simple CSS background

Categories

(Firefox :: General, defect, major)

3.5 Branch
x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 102695

People

(Reporter: adog328, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

This page works fine in all browsers but Firefox 3.5. The CSS for the background the links are in is as follows. 

.menu
{
border-left: 2px solid #3366FF;
border-right: 2px solid #3366FF;
border-bottom: 2px solid #3366FF;
text-align: center;
font-family: Verdana;
background-color: #FFFFFF;
}


As you can see the first link works, the second links is awkward and blinks off, and the other two will not work. This is most definately a problem isolated only to firefox, and not to CSS coding. I validated my CSS code with 3 differant tools, so it is of course correct. 



Reproducible: Always

Steps to Reproduce:
1. Make an html page, and add the CSS file containing the script shown in the details.
2. <div class="menu"> Then add a 3-4 basic links to any sites you wish using <a href=""> </div>

Actual Results:  
Half of the links did not show, and the 2nd link blinked off as soon as you went over it.

Expected Results:  
The links should have been clickable and were not.
Severity: normal → major
Version: unspecified → 3.5 Branch
Attached file testcase (obsolete) —
Tyler, like so?
Attached file non-broken testcase
Attachment #386329 - Attachment is obsolete: true
Keywords: testcase
Please check the above website, you will see the problem, I confirmed the problem with 10 people.  I will also attach the index.htm file as well as the styles.css
index.htm
Attached file CSS for the bug
Tyler, does my test case work?  We need reduced test cases so we know exactly what code is causing the issue and not having to sift through hundred(s) of lines of CSS and code ;)
Your test case works fine, but they are not in seperate files... like I stated before, the website works perfectly in ALL other browsers except this version of firefox. Therefore, it must be a bug. You can see how it does that if you visit the website listed above. The CSS is somehow blocking the link from working. Its very simple CSS,as you can see, and should work fine.
I posted a test case adding my CSS to your portion of code.
In the original URL, the login panel (div class="login") is covering the links, because the 400px height. As a result one can't click through on the links. Add a background-color to the .login to see the problem.
That is the correct behaviour, btw.

The same problem happens with Gecko 1.9.0.x (FX 3.0.11 & 3.0.12 pre) and WebKit based browsers (Safari, Chrome).

.login  {
color:white;
float:right;
font-family:Tahoma;
height:400px; /* <----------- there
left:460px;
padding:1em;
position:absolute;
top:48px;
width:1000px;
}

Either INVALID or a dupe of an old bug that I'll need to look up.
ahh, thanks! I'd love to see that problem fixed in the near feature though.
(In reply to comment #11)
> ahh, thanks! I'd love to see that problem fixed in the near feature though.
Don't hold you breath, though :-)
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 102695
You need to log in before you can comment on or make changes to this bug.