dom.disable_window_open_feature.location ignored if location bar is placed in menu toolbar and navigation toolbar is hidden

RESOLVED DUPLICATE of bug 258913

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED DUPLICATE of bug 258913
9 years ago
9 years ago

People

(Reporter: Yet Ding, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

dom.disable_window_open_feature.location = true is the default setting in FireFox.

The FireFox menu bars can be set up so that the location bar is placed in the menu toolbar and the navigation toolbar is hidden.

This configuration allows sites to create popup windows with the location bar hidden thus ignoring the aforementioned setting.

Reproducible: Always

Steps to Reproduce:
1. Move location bar item to menu toolbar.
2. Hide navigation toolbar.
3. Navigate to a site that attempts to hide the location bar in popups.
Actual Results:  
The location bar is hidden.

Expected Results:  
The location bar should be visible.

If dom.disable_window_open_feature.location is set to true (the default setting in FireFox) the location bar should be visible regardless of where the user chooses to place the location bar.

Updated

9 years ago
Component: Security → Toolbars
Keywords: qawanted
QA Contact: firefox → toolbars
Version: unspecified → 3.5 Branch

Updated

9 years ago
Depends on: 337344
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Keywords: qawanted → uiwanted
Resolution: --- → DUPLICATE
Duplicate of bug: 258913
Keywords: uiwanted
You need to log in before you can comment on or make changes to this bug.