Automatically add/remove a new locale to the language table on enable/disable

VERIFIED FIXED in 1.3

Status

support.mozilla.org
Localization
--
minor
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: paulc, Assigned: paulc)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tiki_test)

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
Currently, when you enable a language in the tiki admin i18n panel, the language does not get added to the language table. For example, it is not available in the interactive translator. We should add/remove the language automatically.

For an example when this was confusing, see bug 492774.
(Assignee)

Comment 1

9 years ago
Sylvie, is this fixed in Tiki yet? Can you point me to it if so? And if not, perhaps you'd like a patch for it?

Comment 2

9 years ago
Sorry I do not know - I never used the interactive translator
The best will be to download a tiki3 - test - and if problem ask on the devel list.
(Assignee)

Comment 3

9 years ago
Created attachment 386610 [details] [diff] [review]
patch, v1

It seems to be fine if we just use the $prefs['available_languages'] array instead.
Attachment #386610 - Flags: review?(smirkingsisyphus)
Attachment #386610 - Flags: review?(laura)

Comment 4

9 years ago
Comment on attachment 386610 [details] [diff] [review]
patch, v1

QA will need to regression test on this one.
Attachment #386610 - Flags: review?(smirkingsisyphus)
Attachment #386610 - Flags: review?(laura)
Attachment #386610 - Flags: review+
(Assignee)

Comment 5

9 years ago
r48090 / r48091
QA: please see comment 4
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Are the steps to reproduce as follows:?

1. Load https://support-stage.mozilla.org/tiki-admin.php?locale=en-US&page=i18n
2. Select, say "eo", click Save
3. Load https://support-stage.mozilla.org/tiki-edit_languages.php?locale=en-US&interactive_translation_mode=on
4. Look at the "Select the language to edit" pulldown

Was the bug that it didn't appear in comment 4?  Where should I look for regressions?  Thanks!
(Assignee)

Comment 7

9 years ago
(In reply to comment #6)
Yes. Good STR.
Regressions are more probable on tiki-edit_languages.php, the rest of the pages should be unaffected... but of course that's based on the assumption that the list of languages has proper values set :)
Thx for the confirmation, Paul; verified fixed per comment 6.  I'll also of course keep an eye out for regressions.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

9 years ago
Whiteboard: tiki_triage

Updated

8 years ago
Whiteboard: tiki_triage → tiki_test
You need to log in before you can comment on or make changes to this bug.