If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Select a column from an HTML table, copy and paste into Excel doesn't paste properly

RESOLVED DUPLICATE of bug 458518

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 458518
8 years ago
8 years ago

People

(Reporter: David Charlap, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

With Firefox 3.0.*, on Mac OS X, I could CMD-drag to select a column of cells from an HTML table, copy (with CMD-C), and then paste it into Excel 2004 (with CMD-V), and it would put each HTML table cell into a separate Excel spreadsheet cell.

With 3.5, this doesn't work.  Now, it runs all the text from all the HTML cells together and it pastes as one huge string.  If I do a "paste special" in Excel and select plain text, however, it pastes correctly.

I don't know what changed between version 3 and 3.5 to cause this, but I think 3.5's behavior is less correct than 3's was.

Reproducible: Always

Steps to Reproduce:
1. Go to the above URL (http://mysite.verizon.net/dcharlap/DavidFAQ/index.html)
2: CMD-drag (or Ctrl-drag on Windows) to select a region of table-cells
3: Copy to the clipboard (CMD-C on Mac, Ctrl-C on Windows)
4: Open Excel (I used 2004 on Mac OS, 2003 on Windows)
5: Select a cell and Paste (CMD-V on Mac, Ctrl-V on Windows)
6: Select a different cell, paste-special, selecting Text format
Actual Results:  
In step 5, all the text from the selected cells is concatenated, ending up as one huge string in the Excel cell.

In step 6, each cell from the original HTML table gets pasted into a separate Excel cell, preserving the original layout.

Expected Results:  
Both steps 5 and 6 should've pasted in the same way - with each HTML cell becoming a separate Excel cell.

This may be a reversion of something.

On the Mac platform, this worked as expected in Firefox 3.0.*

On the Windows platform, this behavior occurred in 3.0 as well.
Not a shell integration bug. Over to general and this is a dupe of bug 458518 or one of the other paste into excel bugs
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Shell Integration → General
QA Contact: shell.integration → general
Resolution: --- → DUPLICATE
Duplicate of bug: 458518
You need to log in before you can comment on or make changes to this bug.