Symbian emulator should defines as i386, not ARM.

RESOLVED FIXED in 4.8.1

Status

NSPR
NSPR
P1
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: m_kato, Assigned: m_kato)

Tracking

other
4.8.1
x86
Symbian

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2.72 KB, patch
Nelson Bolyard (seldom reads bugmail)
: review+
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
Created attachment 386437 [details] [diff] [review]
patch v1

Symbian emulator (WINS / WINSCW) is i386 architecture, not ARM.  But current NSPR defines as ARM.  It should not define as it.
Attachment #386437 - Flags: review?(wtc)
Comment on attachment 386437 [details] [diff] [review]
patch v1

After reviewing the patch, I see that the issue here is *not* with any symbol
that is defined (definition is created) by NSPR, but rather the issue is 
that NSPR only tests for the presence of __WINS__ when __arm__ is also defined, 
rather than treating those symbols as mutually exclusive.

The patch changes the behavior so that effectively __WINS__ is an alternative 
to, and mutually exclusive with, __arm__.  Since this change only affects 
files that that are only built in symbian builds, I have no objection to 
this change.  r=nelson
Attachment #386437 - Flags: review?(wtc) → review+
pr/include/md/_symbian.cfg; new revision: 1.4; previous revision: 1.3
pr/include/md/_symbian.h;   new revision: 1.2; previous revision: 1.1
Assignee: wtc → m_kato
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Priority: -- → P1
Resolution: --- → FIXED
Target Milestone: --- → 4.8.1
You need to log in before you can comment on or make changes to this bug.