debug msgs in release version of mozilla

RESOLVED FIXED

Status

SeaMonkey
General
P3
critical
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: TkThyag, Assigned: Judson Valeski)

Tracking

({embed})

Trunk
All
Linux
embed

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (WinNT; U)
BuildID:    20000801120 

Number of (debug) msgs are printed to stdout and stderr even in the release 
build 
of mozilla. For instance

WEBSHELL+= , WEBSHELL-= in nsWebShell.cpp
=== cannot get lang group for jis-0201 in nsFontMetricsGTK.cpp
CSSLoaderImpl::LoadAgent: Load of URL 'blah blah blah' failed. Error code: 
XXXXXX  in nsCSSLoader.cpp

Reproducible: Always
Steps to Reproduce:
goto www.real.com to see all types of output	

Actual Results:  							

Expected Results:  dont print any messages to the console in release builds

Comment 1

17 years ago
There probably shouldn't be a console at all in release builds...

Comment 2

17 years ago
marking invalid, just don't specifically ask for the console if you don't want 
it (or file a separate bug to remove the console completely if you really feel 
strongly about it)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
mozilla releases courtesy nightly and milestone binaries.  These builds are
still intended for developers.  If this is about a Netscape release, then it
doesn't belong in bugzilla.

Comment 4

17 years ago
marking verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

17 years ago
I should have been more specific. By console I meant, stderr and stdout. 
Irrespective of anything, the release versions of mozilla (and also the 
nightlies) should not be printing messages. I see the exact same behavior in 
Build ID: 2000090708
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 6

17 years ago
I don't see how this clarification differs any from the original description.  
Mozilla nightlies are intended for developers and will continue to have a 
console if you ask for one.   If you don't want console messages printed in a 
*Netscape* release build, you need to file that at Netscape's Netscape 6 Bug 
Reporting Form.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

17 years ago
It is not a netscape release build I am referring to. It is mozilla built with 
ndebug=1 option. So I am not sure why Blake Ross is reiterating as netscape 
release build. 

Also, just running the nightly build on Linux spits out all the messages. My 
point is that release builds are characterized by atleast one thing, *no debug 
style messages* such as "WEBSHELL += n"  or "->>>>>>>>>> Write Clipboard to 
memory" when you mark something on a page. It may be for developers, but the 
question is does it have to spit out messages as above? or am I being to uppity!

Comment 8

17 years ago
Trying this again.

Mozilla is primarily for developers.  Nightlies and Milestones aren't 
necessarily "final release builds", they're merely snapshot builds so outsiders 
may see the progress of Mozilla if they desire (realizing that it is still 
under construction and NOT finished).  Yes, messages such as "WEBSHELL += n" 
and "Write Clipboard to memory" are very important for both developers and QA 
alike.  Often a JS error, for example, will appear in the console when 
something isn't working properly and can help in bug triage and bug fixing.
(Assignee)

Comment 9

17 years ago
accepting.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Assignee)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 10

17 years ago
taking
Assignee: asa → valeski
(Assignee)

Updated

17 years ago
Keywords: embed, nsbeta3
Whiteboard: [nsbeta3+]
is this a rfe request for a nodebug tag for mozilla? 

Comment 12

17 years ago
I just want to make sure here that we're not talking about turning this off by
default in mozilla builds (even the non-debug ones).  What's wrong with
redirecting it to /dev/null if it's so offensive.  we push courtesy non-debug
binaries each day for mozilla testers and developers.  This is useful
information in those builds and I don't want to see it disappear.  

Comment 13

17 years ago
I believe this bug is a RFE or should be marked invalid.

There are many released applications that dump messages to stderr and stdout
while running. Among these is X, various window managers, editors, games,
graphics programs, system daemons through syslog, etc, etc, etc. Mozilla dumping
messages to stderr and stdout is standard practice.

Furthermore, mozilla has not been released. When mozilla has been released you
can rightfully complain about debug messages.
or, this is a netscape commercial build only.  I heavily doubt mozilla.org wants
this.
(Assignee)

Comment 15

17 years ago
I've got this bug and will be cleaning it up. please do not invalidate this bug.
(Assignee)

Comment 16

17 years ago
I've nailed 3 of these, almost done on the last.
Valeski@netscape.com - I'm still confused as to what the bug is. Are you
reducing the output to console on nightly builds or for netscape releases?
(Assignee)

Comment 18

17 years ago
if the nightly builds are relase builds, then they will be reduced too. if
people need debug info at release time, bugs need to be filed against module
owners to use FORCE_NSPR_LOGGING and they must use the PR_LOG facilities.
(Assignee)

Comment 19

17 years ago
these are gone now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
valeski - so, this is only going to be in netscape release builds? and I need a
commercial build to test this so I can verify it?
(Assignee)

Comment 21

17 years ago
no, I don't work on netscape specific stuff, mozilla only. these were leftover 
debug comments that were intended to be release only. if you have specific areas 
in which you'd like to capture console output during *release* builds, please 
file bugs against the module owners in those areas asking them to use 
NSPR_LOGGING_FORCE.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.