If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

hp.com - Confuses Mozilla/NS6 with NN4

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P2
normal
VERIFIED FIXED
17 years ago
2 years ago

People

(Reporter: blandon ray, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(Whiteboard: [USERAGENT], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000824
BuildID:    2000082404

(I know that's a lame summary, but I'm not a JavaScript programmer.)

Attempting to view http://www.hp.com/cposupport/jsnav/prhome.html, which in
Communicator 4.75 loads a nested series of drop-down menus (apparently generated
by JavaScript). The content of each subsequent menu is dependent on the previous
selection. In Mozilla, the menus never appear and the "loading product info..."
banner never goes away.

Reproducible: Always
Steps to Reproduce:
Stopped/started Mozilla and Comm. 4.75, and navigated again to above URL.

Actual Results:  Document continued to appear as described above (menus do not
load), whereas 4.75 browser loads the page correctly and quickly each time.

Expected Results:  Menu items should appear as in Communicator.

(didn't test on IE, as this machine is a lobotomized 98lite version)

Comment 1

17 years ago
Browser, not engine. Reassigning to Browser-General -
Assignee: rogerl → asa
Component: Javascript Engine → Browser-General
QA Contact: pschwartau → doronr

Comment 2

17 years ago
This is an interesting one. Have to mark it invalid, however,
because the HTML file tests the browser version incompletely.
Here is the browser test: 

  function setUpStuff() {
    ns4 = (document.layers) ? 1:0;  
    ie4 = (document.all)   ? 1:0;

	etc. 


This may test accurately for IE4 and NS4, but in Mozilla, you will get 
ns4=0 and ie4=0 because Mozilla supports neither layers nor document.all 

This will have bad consequences later in the code -


If I save this HTML file  http://www.hp.com/cposupport/jsnav/prhome.html 
locally (to get an accurate line count), I get the following error in the 
JavaScript console (Tasks --> Tools --> JavaScript Console):

Error:         dropdownObjectPath is not defined
Source File:  (local path to HTML filel)
Line:          302


Here are the relevant lines in the HTML file: 

292    function repopulateOptions(whichLayer, whichDropdown, withWhat) {
293      // Set up dropdownObjectPath for easy cross-browser access
294      if (ns4) { 
295        dropdownObjectPath="document.layers[\"" + whichLayer + 
296                           "\"].document.forms[0]." + whichDropdown;
297      }
298      if (ie4) {
299        dropdownObjectPath="document.all[\"" + whichDropdown + "\"]";
300      }
301  
302      oldLength=eval(dropdownObjectPath + ".length"); 
                                                                     

You can see that on line 302, the code attempt to use dropdownObjectPath. 
However,  dropdownObjectPath was only defined (if ns4) on line 295 
or (if ie4) on line 299. Since in Mozilla both ns4 and ie4 = 0, 
it never gets defined. This is the error...

For a reference of what is supported in Gecko/Nav5, see these comments 
from bug 41765:

   ------- Additional Comments From Asa Dotzler 2000-06-07 10:10 -------

   INVALID. LAYER, ILAYER, document.layers[] not supported in Gecko/Nav5.
   Notified reporter and site owner via template at
   http://sites.netscape.net/ekrock/fixit/layer.html
   See http://sites.netscape.net/ekrock/standards.html for details 
   on standards-compliance in Mozilla, and which proprietary features 
   of NS 4.x and IE will not be supported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Assignee)

Comment 3

17 years ago
over to evangelism
Component: Browser-General → Evangelism
Summary: Dynamic JS menu elements not loading → [LAYER]Dynamic JS menu elements not loading

Comment 4

17 years ago
really reassigning..
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

17 years ago
Assignee: asa → blakeross
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: doronr → zach

Comment 5

17 years ago
...

Comment 6

17 years ago
-> evangelism@telocity.com for my evangelism bugs.

removing the now-depreciated evangelism-related keywords.

setting platform to All.
Assignee: blakeross → evangelism
Hardware: PC → All

Comment 7

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary

Comment 8

17 years ago
Page is now redirected to http://www.hp.com/cposupport/eschome.html.

The page uses a version of the Ultimate Browser Sniffer but treats
Mozilla/Netscape 6 like NN4 with regard to CSS/Style Sheets since it uses
is_nav4up and is_nav.

It also uses a 4.01 loose DOCTYPE with URI, but the major problem at the moment
is the browser detection.

Changing summary from 
[LAYER]Dynamic JS menu elements not loading 
to 
[USERAGENT] Confuses Mozilla/NS6 with NN4

Changing URL from
http://www.hp.com/cposupport/jsnav/prhome.html
to
http://www.hp.com/cposupport/eschome.html

Marking OS All
Upgrading priority from P3 to P2
Accepting bug.
Status: NEW → ASSIGNED
OS: Windows 98 → All
Priority: P3 → P2
Summary: [LAYER]Dynamic JS menu elements not loading → [USERAGENT] Confuses Mozilla/NS6 with NN4

Comment 9

16 years ago
Still has problems with detection and table coloring. Reassign to me.
Status: ASSIGNED → NEW

Updated

16 years ago
Summary: [USERAGENT] Confuses Mozilla/NS6 with NN4 → hp.com - Confuses Mozilla/NS6 with NN4
Whiteboard: [USERAGENT]

Comment 10

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified
(Assignee)

Comment 11

16 years ago
site still sees us as ns4, but comparing it to ie5 I see no difference.
Whiteboard: [USERAGENT] → [USERAGENT][aok]

Comment 12

16 years ago
Mass reassign of all tech-evangelism us general bugs assigned to bc to 
doron except bc's P1 bugs. You may search for this mass reassign (it is 
305 bugs) by searching for the keyword 'greeneggsandham'
Assignee: bclary → doronr

Updated

16 years ago
Keywords: evang500
Whiteboard: [USERAGENT][aok] → [USERAGENT]
can't find a problem.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Comment 14

15 years ago
v
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.