Unable to easily select large ranges of table cells with SHIFT+CTRL

NEW
Unassigned

Status

()

10 years ago
3 years ago

People

(Reporter: egil, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

In current version of FF I'm unable to easily select a large ranges of table cells with SHIFT+CTRL. By selecting I mean selection available only for table cells (FF marks cells with a blue border).

Reproducible: Always

Steps to Reproduce:
1.Press CTRL and click on a first table cell in your range
2.Move to a place where the last table cell in your range is visible
3.Press CTRL+SHIFT and click on the last table cell in your range
Actual Results:  
Only two cells are selected.

Expected Results:  
All cells in range should be selected (range is a rectangle of selected cells that has one of the cells in upper left corner and the other cell in the lower right corner).

It used to work with FF 3.0. I know that I can hold SHIFT+CTRL to select ranges, but this is far less usable as it always selects rows or columns.
I can reproduce the impossibility you experience in 3.5.
I've tested with http://www.w3schools.com/html/html_tables.asp .
This is possibly a regression. I'll hold on for someone to confirm this with me so  I can change status to NEW.
Keywords: regression, regressionwindow-wanted
Ups, I forgot to mention, tested in Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2a1pre) Gecko/20090707 Minefield/3.6a1pre (.NET CLR 3.5.30729)
I'm gonna change the x86 bit part because I'm using x64 and im gonna change the OS because I'm using Windows 7. In this kind of bugs, it's likely for them to happen in every possible platform.
OS: Windows XP → All
Hardware: x86 → All
It works in Firefox according to Kbrosnan (he should be posting here something soon) so it's a regression.
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.9.1 Branch
Err, I meant, It works in Firefox 3.5. Sorry.

Comment 6

10 years ago
I see the same issue on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Updated

10 years ago
Component: General → Selection
Flags: blocking1.9.2?
QA Contact: general → selection
Today I must have a big headache. It's a regression nevertheless. So the change in the code happened somewhere between Firefox 3.0.11 and Firefox 3.1b3(Mozilla/5.0 (Windows; U; Windows NT 6.1; pt-PT; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3 (.NET CLR 3.5.30729)) Yes. I've tested there.
Pressing CTRL and dragging the mouse does the same, but maybe the shortcut is important for long tables where you can't affoard to drag all the way down.
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b2pre) Gecko/20081122 Minefield/3.1b2pre (.NET CLR 3.5.30729) <- Same Issue.
I need to keep installing older builds. Argh.
Ok, Window mostly determined. The isssue is revealed between alpha 1 [Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1a1) Gecko/2008072310 Shiretoko/3.1a1 (.NET CLR 3.5.30729)), when it still works and alpha 2, (Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1a2) Gecko/20080829082037 Shiretoko/3.1a2 (.NET CLR 3.5.30729)), where it works no more. 

The issue occurs between 2008/07/23 and 2008/08/29 (i guess?) so it's a one-month timeframe. I'll try to test any nightlies within these timeframes.
Ok, trying to reduce the timeframe.
Change was between 2008/08/02 and 2008/08/11
OK I determined the cause.
http://hg.mozilla.org/mozilla-central/rev/730dd065f606
^^ That was the thing that broke it.
Now we have to wait for someone to propose a patch... 
I've did my best at the regression window. After regressing about an year, I'm tired. Going to sleep soon.
I can remove the keyword regressionwindow-wanted . How good that feels.
Keywords: regressionwindow-wanted
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Flags: blocking1.9.2?
Resolution: --- → DUPLICATE
Duplicate of bug: 474458

Comment 13

10 years ago
This is a issue that can't be reproduced in the 1.9.0 branch and can be in 1.9.1. Could you explain why this bug was duped to a bug that was found in the 1.9.0 branch?
no way this is a dupe of Bug 474458. i checked a regrange for Bug 510163 what is http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-08-09+03%3A39%3A29&enddate=2008-08-11+05%3A37%3A24 what clearly points to Bug 210197 as cause => thus reopening this one.
Blocks: 210197
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Duplicate of this bug: 510163
Wow, I can't believe I can still reproduce this bug in Firefox 5...
(In reply to comment #16)
> Wow, I can't believe I can still reproduce this bug in Firefox 5...

Don't do that, it does not get Things get fixed any faster. The Status clearly says "NEW".
Version: 1.9.1 Branch → Trunk

Comment 18

3 years ago
Dup of bug 185900?
You need to log in before you can comment on or make changes to this bug.