Default Content-type for PUT XMLHttpRequests is text/plain instead of [application/xml; charset=UTF-8]

RESOLVED INVALID

Status

()

Core
DOM
RESOLVED INVALID
9 years ago
7 years ago

People

(Reporter: Karen Teng, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_7; en-us) AppleWebKit/525.28.3 (KHTML, like Gecko) Version/3.2.3 Safari/525.28.3
Build Identifier: 3.5

In Firefox 3.1 we were able to send PUT requests without specifying the Content-type in the header as it defaulted to the correct value. In Firefox 3.5 the default value seems to be text/plain which screws up our signature signing to various web services. 

Reproducible: Always

Comment 1

9 years ago
This behavior was changed in bug 464848.
Component: General → DOM
OS: Mac OS X → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: unspecified → Trunk
Looks correct to me:

http://dev.w3.org/2006/webapi/XMLHttpRequest-2/#dom-xmlhttprequest-send
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.