Recent changes for OOM has cause a performance degradation on ARM

VERIFIED INVALID

Status

Tamarin
Garbage Collection (mmGC)
VERIFIED INVALID
9 years ago
9 years ago

People

(Reporter: Brent Baker, Unassigned)

Tracking

unspecified
ARM
Windows Mobile 6 Professional
Bug Flags:
flashplayer-triage +

Details

(Reporter)

Description

9 years ago
Recent changes for OOM have a negative effect on performance.

changeset: http://hg.mozilla.org/tamarin-redux/rev/f191af594659

This can be seen as a small 3% drop in the mirco benchmarks that are in "test/performance"
http://tamarin-builds.mozilla.org/report/index.cfm?hostip=10.60.147.192&config1=&config2=&configbaseline=&baselineBuild=2026&topBuild=2045&prevBuild=2026&product1=tamarin-redux&product2=tamarin-redux&productBaseline=tamarin-redux&raw=false&ratio=true&verbose=false&group=Desktop&metricsChecked=time

However running some internal performance tests have shown that the performance drop is much more significant when using larger applications, in the neighbourhood of 400%  (one benchmark ran in 25 seconds in rev 2038 and 120 seconds in rev 2039)
Flags: flashplayer-triage+
Flags: flashplayer-qrb?
(Reporter)

Comment 1

9 years ago
This was all caused by how I was compiling. In order to enable memory profiling on windows mobile you need to enable it then compile. This shell will be seriously impacted performance wise since it must track all memory allocations
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

9 years ago
removing QRB request, bug resolved/verified invalid
Flags: flashplayer-qrb?
You need to log in before you can comment on or make changes to this bug.