Closed Bug 501981 Opened 11 years ago Closed 11 years ago

Impossible to select the current tab by clicking on it (no focus rect around the tab title)

Categories

(Firefox :: Tabbed Browser, defect, minor)

3.5 Branch
defect
Not set
minor

Tracking

()

VERIFIED WONTFIX

People

(Reporter: Ricmacas, Unassigned)

References

Details

(Keywords: regression)

Hello, today at SUMO-livechat I got this bug report from a user, which I then asked whimboo and now I'm filling the bug.
User's description:
"I almost always use multitabs, and you could just click on the tabs to get the dotted box around the tab title, then use the arrow keys to move left or right to different tabs. You can no longer click on the tab to select it, but you can use the Tab key to get a selection still, however."
Smells like regression. I can reproduce.
This happens on all platforms and regressed between 3.1 beta 3 and 3.5 beta 4. We need a closer range to narrow down the problem. Anyone interested?
Severity: minor → normal
Flags: wanted1.9.1.x?
OS: Windows NT → All
Hardware: x86 → All
Summary: Impossible to select the current tab by clicking it (getting the dotted box around the tab title) → Impossible to select the current tab by clicking on it (no focus rect around the tab title)
This is intentional.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
Natch: Sorry then. A user was worried about this, so I thought it would be good to file.
Also, why is it intentional? Would it conflict with the new tabbing system that allows you to "(un)dock" tabs from a window to another??
Severity: normal → minor
OS: All → Windows NT
Hardware: All → x86
Resolution: WONTFIX → FIXED
Please don't change the resolution. WONTFIX is the correct value.
Resolution: FIXED → WONTFIX
See the dependent bug for an explanation of why this was done, I think it was a ux/ui decision.
Status: RESOLVED → VERIFIED
OS: Windows NT → All
Hardware: x86 → All
Duplicate of this bug: 509768
Flags: wanted1.9.1.x?
You need to log in before you can comment on or make changes to this bug.