freeze on page with a few thousand radio/checkbox inputs

VERIFIED DUPLICATE of bug 477564

Status

()

VERIFIED DUPLICATE of bug 477564
9 years ago
9 years ago

People

(Reporter: gilleswork, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Firefox freezes for a while on a page with a few thousand radio/checkbox inputs:
- after loading the page, that is, the page has completely rendered, but then FF freezes
- when hiding/showing some inputs
- when clicking on the inputs repeatedly

On the attached page, it's freezing for a few seconds, but on a bit more complicated layouts with about 3000 checkboxes it can freeze for several minutes.


Reproducible: Always

Steps to Reproduce:
1. Load the attached page. It creates 3000 radio inputs.
2. Click on different input buttons one after the other, until FF freezes. It usually takes me less than 20 clicks until it freezes.




It does the same thing when running FF in safe mode.

It works fine with FF 3.0.11.

Please tell me if there's something else I can do to help locate the problem.
(Reporter)

Comment 1

9 years ago
Created attachment 386545 [details]
Creates 3000 radio buttons

Test case to show that clicking different radio buttons one after the other makes FF 3.5 freeze for a while.
(Reporter)

Comment 2

9 years ago
For some reason, when I try the attached page directly from bugzilla, it doesn't reproduce the problem. So you might want to first download the file, and open it. I had someone else using FF 3.5 try that same file, and he had the same problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 477564

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.