Drag-and-drop (Rico/prototype) no longer working in Firefox 3.5

RESOLVED DUPLICATE of bug 501885

Status

()

--
major
RESOLVED DUPLICATE of bug 501885
9 years ago
9 years ago

People

(Reporter: billg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

The drag-and-drop facility provided by the OpenRico library no longer works in FireFox (3.5 B2, and now release). It still works in FF2, FF3, IE7, IE8 and Opera 9, all tested on Windows XP SP3.  When clicking on the draggable area, error console says "draggable.isSelected is not a function" though no such error appears in other browsers (including older versions of FF).

Reproducible: Always

Steps to Reproduce:
1.Go to http://demos.openrico.org/demos/drag_and_drop_simple
2.Try to drag orange "drag me" box
3.See error logged in error console.
Actual Results:  
The box does not appear to be draggable, and the error noted above is logged to the error console.

Expected Results:  
The box should be draggable.

I suspect this indicates some larger problem, and isn't specific to the rico code, since all other browsers seem to work as expected.
(Reporter)

Comment 1

9 years ago
Well, my initial search for 'openrico' in bugzilla turned up nothing, but this is clearly a dup of 501885.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 501885
You need to log in before you can comment on or make changes to this bug.