[JavaScript Application] Error: current_domain is null

RESOLVED INVALID

Status

()

RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: a.barcomb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

Since at least two builds ago, but not with the previous stable release, I see a popup message '[JavaScript Application] Error: current_domain is null' at startup.  My startup page appears to be triggering this; however, the startup page contains no JavaScript at all, just lazy HTML consisting of only the tags ul, li, and href (no html, head, body, or doctype declaration). 

Reproducible: Always

Steps to Reproduce:
1. Start up browser with startup page containing incorrect HTML.
2.
3.
Actual Results:  
JavaScript error message popup.

Expected Results:  
I would expect to see no error message, as poorly-formatted HTML exists.

I cannot rule out at this point if the problem is related to an extension which was updated (longurl) recently.  All other extensions have either remained the same since the last stable version, or have been disabled in the upgrade process.
(Reporter)

Comment 1

9 years ago
Problem appears to stem from extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.