If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<img> with invalid src (and w or h unspecified) doesn't resize from 0 size when src changed by javascript

RESOLVED FIXED in Future

Status

()

Core
Layout
P3
normal
RESOLVED FIXED
17 years ago
15 years ago

People

(Reporter: Chris Waterson, Assigned: Chris Waterson)

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1005 bytes, text/html
Details
(Assignee)

Description

17 years ago
See attached test case. To reproduce:

1. Open test case.
2. Click button.

Expected behavior: see a squished image appear
Actual: nothing happens
(Assignee)

Comment 1

17 years ago
My guess is that this is a layout problem, and has to do with replaced frames. I
tried another test case where the initial image points to a valid image file
(instead of "about:blank") and it worked.
Status: NEW → ASSIGNED
Component: DOM Level 0 → Layout
Summary: document.images[0].src = '...' does not work → document.images[0].src = '...' does not work if original image invalid
Target Milestone: --- → Future

Comment 2

16 years ago
Will this bug fixed before Mozilla ver. 1.0 ?

Comment 3

16 years ago
Since there is no testcase, I can only guess but I think this is the same as bug
22820.

Comment 4

15 years ago
Created attachment 119960 [details]
testcase

Updated

15 years ago
Keywords: testcase
Summary: document.images[0].src = '...' does not work if original image invalid → <img> with invalid src (and w or h unspecified) doesn't resize from 0 size when src changed by javascript
This is in fact a dup of bug 22820, but I regressed that.... the new bug on the
issue is bug 198435.
Depends on: 198435
Fixed by bug 198435
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
*** Bug 202650 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.