Remove dead plugin scripting code.

RESOLVED FIXED in mozilla1.9.2a1

Status

()

Core
DOM
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: jst, Assigned: jst)

Tracking

Trunk
mozilla1.9.2a1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 386651 [details] [diff] [review]
Remove dead code.

Now that we no longer support XPCOM plugins there's some code in nsDOMClassInfo.cpp that no longer does anything useful. See attached patch.
Attachment #386651 - Flags: superreview?(mrbkap)
Attachment #386651 - Flags: review?(mrbkap)
(Assignee)

Comment 1

8 years ago
Oh, and this patch also adds an ObjectIsNativeWrapper() check to nsHTMLPluginObjElementSH::Call(), since I think that's what we want to do there...
Comment on attachment 386651 [details] [diff] [review]
Remove dead code.

The world just got a little bit brighter.
Attachment #386651 - Flags: superreview?(mrbkap)
Attachment #386651 - Flags: superreview+
Attachment #386651 - Flags: review?(mrbkap)
Attachment #386651 - Flags: review+
(Assignee)

Comment 3

8 years ago
Fixed, and I updated the comment about the prototype layout before and after we script a plugin as well...

http://hg.mozilla.org/mozilla-central/rev/457417981271
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Depends on: 536116
Version: unspecified → Trunk
Depends on: 524649
Thanks to Daniel we were able to see that the removal has also been affected NPAPI plugins. The regression is covered on bug 524649.
OS: Linux → All
Hardware: x86 → All
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.