Allow the user to select a bookmark folder for use as the Bookmark Toolbar

RESOLVED DUPLICATE of bug 400386

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED DUPLICATE of bug 400386
8 years ago
8 years ago

People

(Reporter: Carl Menezes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

This is related to sharing bookmarks across multiple computers. 

Here is the real life use case that made me think of this:

My wife and I use bookmark synching on Firefox.

She uses the bookmark toolbar at home to store bookmarks about shopping and furniture, etc..

I use the bookmark toolbar at work for Live bookmarks for the work wiki, bugs, etc.

We both use different bookmark profiles, but when she adds a bookmark at home (say about a new couch), it appears on the toolbar at work. 

The reason is because bookmark toolbar items are stored in the same folder, so even XMarks (or Weave) will not be able to tell whether it should sync a toolbar bookmark across all computers on all profiles or not.

Now, if you could specify which folder could be used for the bookmark toolbar, it would eliminate the problem, because each profile would be storing and retrieving bookmarks from different folders.

Thoughts? Do you think there is a better solution? 

Reproducible: Always
Weave and Xmarks sync bookmarks.  That's what they do.  Doesn't really have anything to do with the bookmarks toolbar folder.  If you'd like to be able to exclude certain folders or bookmarks from syncing, you should file a feature request with Weave or Xmarks, but I'd be surprised if they couldn't do that already.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 400386
You need to log in before you can comment on or make changes to this bug.