Folders do not display, most actions generate _treeElement undefined errors

RESOLVED INVALID

Status

Thunderbird
Mail Window Front End
--
critical
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Miquel Rodríguez Telep, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090701 Ubuntu/9.04 (jaunty) Shiretoko/3.5.1pre FirePHP/0.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090702 Shredder/3.0b3pre

After installing today's daily Thunderbird 3 / Shredder build for Ubuntu Jaunty from a PPA repository (https://edge.launchpad.net/~ubuntu-mozilla-daily/+archive/ppa), folders will not display in the side pane upon start up, which remains completely blank.

The main start page is shown in the right pane, but clicking on most items (i.e. read messages, write a message, etc.) does nothing. I can, however, start an e-mail by launching TB with the -compose switch. I was also once able to use the Edit > Find > Search Messages... function to find and open an e-mail, though I can no longer reproduce that behavior and instead the search window will not open.

Additionally, the tab item at the top displays no text and a generic folder icon.

The error console displays the following on startup:
Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0
Error: Application is not defined
Source File: chrome://messenger/content/tabmail.xml
Line: 1030

Most actions I attempt also generate one of the following errors:
Error: this._treeElement is undefined
Source File: chrome://messenger/content/folderPane.js
Line: 317
Error: gFolderTreeView._treeElement is undefined
Source File: chrome://messenger/content/folderPane.js
Line: 227

Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird 3
Actual Results:  
Folder pane is blank

Expected Results:  
The folder list is displayed

I have run TB3 both with my usual extensions (Lightning and dictionaries -- Lightning works fine in all respects) and in safe-mode with no extensions enabled.
Version: unspecified → Trunk

Comment 1

9 years ago
can you reproduce this with a fresh profile? Since when are you using tbird 3.0? did you just upgrade from tbird 2? Any extensions installed that might cause problems?

Comment 2

9 years ago
sorry. i think i see this too. will investigate

Comment 3

9 years ago
our compare check gave us these potential missing files:

-usr/lib/thunderbird-3.0b3pre/components/NetworkGeolocationProvider.js
-usr/lib/thunderbird-3.0b3pre/components/libucvmath.so
-usr/lib/thunderbird-3.0b3pre/components/nsMailNewsCommandLineHandler.js
-usr/lib/thunderbird-3.0b3pre/components/steelApplication.js

I will add them now; with some luck its fixed in tomorrows dailies then.

Comment 4

9 years ago
bzr commit -m "* add new components files to install (see bmo #502208)
>   - update debian/thunderbird-3.0.install" debian/thunderbird-3.0.install
Committing to: bzr+ssh://bazaar.launchpad.net/~mozillateam/thunderbird/thunderbird-3.0.head/                                                                          
modified debian/thunderbird-3.0.install
Committed revision 114.
Resolving INVALID as this is not a problem with Thunderbird's build setup.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

9 years ago
Sorry, should I report problems with the Ubuntu dailies via Launchpad in the future?

Alexander: The daily builds have been failing so I've been unable to test your fix
(In reply to comment #6)
> Sorry, should I report problems with the Ubuntu dailies via Launchpad in the
> future?
> 

Yes please.

Comment 8

9 years ago
i fixed the build again now; also we moved to static builds; we kicked off a out-of-schedule daily build, so a package for testing should be available any minute.

Comment 9

9 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > Sorry, should I report problems with the Ubuntu dailies via Launchpad in the
> > future?
> > 
> 
> Yes please.

actually i would love to do more stuff upstream. its easier to redirect bugs that turn out to be upstream to the right component in bugzilla instead of forwarding upstream and then the reporter cannot even provide input anymore.

maybe we could create a "ubuntu packages" component where we can move such bugs to?
(In reply to comment #9)
> (In reply to comment #7)
> > (In reply to comment #6)
> > > Sorry, should I report problems with the Ubuntu dailies via Launchpad in the
> > > future?
> > > 
> > 
> > Yes please.
> 
> actually i would love to do more stuff upstream. its easier to redirect bugs
> that turn out to be upstream to the right component in bugzilla instead of
> forwarding upstream and then the reporter cannot even provide input anymore.
> 
> maybe we could create a "ubuntu packages" component where we can move such bugs
> to?

How about we cc a specific email address like Thunderbird-ubuntu@xxx.zzz when we (Thunderbird QA) - figure out that the issue is ubuntu specific ? I think it would be a nice discussion item for one of our weekly calls - Alexander could you join one of them ?
(In reply to comment #9)
> actually i would love to do more stuff upstream. its easier to redirect bugs
> that turn out to be upstream to the right component in bugzilla instead of
> forwarding upstream and then the reporter cannot even provide input anymore.
> 
> maybe we could create a "ubuntu packages" component where we can move such bugs
> to?

I can see issues with both ways of doing it. I'd suggest starting a discussion
in mozilla.dev.apps.thunderbird rather than here.
You need to log in before you can comment on or make changes to this bug.