When using "Sort By Name" on the top level bookmarks folder the static menu items are sorted as well

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: tjchristol, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by Xmarks (formerly Foxmarks) extension])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

When I try to sort my root bookmarks folder (folders/bookmarks visible when clicking on the Bookmarks menu item), what I would consider the "static" menu items (e.g. "Bookmark this page", "Bookmark all tabs", etc.) are sorted along with the bookmarks.  This behavior is maintained until I restart Firefox at which point the static menu items are restored to their original positions.

Reproducible: Always

Steps to Reproduce:
1. Click on Bookmarks menu item
2. Right click "Sort By Name"
3. Static menu items are now sorted
Actual Results:  
Here is what my Bookmarks menu looks like after sorting:

Recent Tags         >
Recently Bookmarked >
----------------------
Arts & Crafts       >
Cycling             >
...
Travel              >
Bookmark This Page
Bookmark All Tabs...
Organize All Bookmarks
----------------------
Bookmarks Toolbar   >
----------------------

Expected Results:  
Here is what my Bookmarks menu looks like after restarting Firefox (and what should happen when sorting by name):

Bookmark This Page
Bookmark All Tabs...
Organize All Bookmarks
----------------------
Bookmarks Toolbar   >
----------------------
Recent Tags         >
Recently Bookmarked >
----------------------
Arts & Crafts       >
Cycling             >
...
Travel              >
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Comment 1

9 years ago
Can you try,

1. Try to reproduce in Safe Mode. http://support.mozilla.com/en-US/kb/Safe+Mode
2. Disable all add-on and see what the minimal set of add-ons installed will
cause this problem to reproduce
3. Try to reproduce in a new profile.
http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 2

9 years ago
1) Does not occur in safe mode
2) Caused by the XMarks extension

Sorry for the trouble.  I will keep these steps in mind before submitting future bugs.  Please withdraw.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Whiteboard: [Caused by Xmarks (formerly Foxmarks) extension]
You need to log in before you can comment on or make changes to this bug.