Firefox 3.5 won't start if browser locale is set to en-GB

RESOLVED INCOMPLETE

Status

()

Firefox
General
--
major
RESOLVED INCOMPLETE
8 years ago
7 years ago

People

(Reporter: Tony Walton, Unassigned)

Tracking

({qawanted})

3.5 Branch
x86
Mac OS X
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5

If the general.useragent.locale proprty is set to en-GB Firefox 3.5 fails to start. A popup window is shown, containing the following XML parse error notification:

XML Parsing Error: undefined entity 
Location: chrome://browser/content/browser.xul 
Line Number 36, Column 1:

<window id="main-window"
^

(sic - note the "window" tag is unterminated).

The problem may be worked round by starting in safe mode and using about:config to set general.useragent.locale to en-US (or other locales, not en-GB)

Reproducible: Always

Steps to Reproduce:
1. Set general.useragent.locale to en-GB (either via about:config or using something like the Quick Locale Switcher extension)
2. Restart Firefox 3.5

Actual Results:  
Firefox fails to start and an error popup is seen containing


XML Parsing Error: undefined entity 
Location: chrome://browser/content/browser.xul 
Line Number 36, Column 1:

<window id="main-window"
^


Expected Results:  
Normal Firefox startup
(Reporter)

Comment 1

8 years ago
This is a regression from previous Firefox releases
Version: unspecified → 3.5 Branch

Comment 2

8 years ago
Well if it works in safe mode then the problem is due to an extension and a bad localization on the en-gb locale in that extension.
(Reporter)

Comment 3

8 years ago
This occurs with *no* extensions installed.

Updated

8 years ago
Keywords: qawanted
(Reporter)

Comment 4

8 years ago
This persists in Firefox 3.5.1

Is there any more information I can supply to expedite a fix for this bug?
(Reporter)

Comment 5

8 years ago
This persists in Firefox 3.5.2

Please could someone somewhere provide a status update on this? This appears not to be due to a plugin (I've reproduced this with all plugins and extensions disabled). It is not difficult to reproduce, as detailed above. It appears this is being ignored; at least someone have the courtesy to explain why.

Comment 6

8 years ago
So this does happen in Firefox's safe mode? http://support.mozilla.com/en-US/kb/Safe+Mode
(Reporter)

Comment 7

8 years ago
This does *not* happen in safe mode. It *does* happen in "non-safe" mode even with all extensions unloaded and all plugins disabled.

My further testing has revealed that in "non-safe" mode and irrespective of plugins and extensions:
 
* It does *not* happen  if I set general.useragent.locale to a completely fictitious locale (bb-XX, for example). Nor does it happen with valid but not-installed locales such as pt-BR or pt-PT as long as the language code is not "en".

* *Any* "en" locale which is not en-US  (not just en-GB) triggers the faulty startup; this applies whether a valid but not installed locale (for instance en-IE) or an invalid locale (en-XX) is used. 

Please let me know if there is any more information I can provide.
What about a new profile? http://support.mozilla.com/en-US/kb/Managing+profiles
(Reporter)

Comment 9

8 years ago
I've tried all the above both under the "default" profile and under a profile called "test".
I'm not able to reproduce the problem. Tony, can you please tell me where you have installed the application and which exact steps you have performed? I would need as much details as possible.

Comment 11

8 years ago
Hi!

I have the same problem.

I had Firefox 3.0.12 installed with the following extensions:

All in one Sidebar 0.7.10
Download Statusbar 0.9.6.5
Firebug 1.4.2
Microsoft .NET Framework Assistant 1.0
Modify Headers 0.6.6
Quick Locale Switcher 1.6.10
Web Developer 1.1.8
Xmarks 3.3.2

Today Firefox suggested me to update browser version to 3.5.2 - I accepted. After update installation I've got subj.
NOTE: after update firefox said that Microsoft .NET Framework Assistant is not compatible with 3.5.2

In safe mode firefox works, but if I disable all extensions the same error appears.

Furthermore I've updated Microsoft .NET Framework Assistant to 1.1, but still recieve this error

I've created new profile and then installed all extensions from my list. Works good.
Nikolay, do you still have your old broken profile? I hope so. It would be great to identify why it happens. So please make a backup of the whole profile folder and uninstall all extensions and themes. Eventually a theme is causing this problem. You have only written that you have disabled all extensions.
(Reporter)

Comment 13

8 years ago
Installation

Machine is a MacBook, 2GHz Core 2 Duo CPU, 1GB Ram. OS is Mac OS X 10.4.11 

uname -a reports

Darwin Tony-Waltons-MacBook.local 8.11.1 Darwin Kernel Version 8.11.1: Wed Oct 10 18:23:28 PDT 2007; root:xnu-792.25.20~1/RELEASE_I386 i386 i386

Background

Prior to upgrading to Firefox 3.5 it was running 3.0.13 with no problems.

3.0.13 was running with the Quick Locale Switcher add-on (https://addons.mozilla.org/en-US/firefox/addon/1333 ) and the locale set to en-GB

On installing Firefox 3.5 there was a warning message regarding Quick Locale Switcher not being suitable for this release of Firefox.  

On restart to start FF3.5 the error message detailed earlier in this bug was seen. No action was then possible apart from quitting Firefox.. This is why I've flagged this as "major" - it's an upgrade issue, someone upgrading from a prior version to 3.5.x gets a non-working Firefox, with no prior warning and no apparent way of getting it to work. This is particularly poor behaviour for a naive user. I'm happy to fire up a different browser and seek about for terms like "safe mode" but you can't expect my silver-haired old Mum to do the same.

After some experimentation, including starting FF 3.5 in safe mode and removing ALL extensions, I found that irrespective of extensions the result was the same.

Extensions installed at this point: none

Themes installed at this point: Default 3.5.2 (only)

I have also tried disabling ALL plugins. Plugins installed and disabled were

Default Plugin 2.0 (Gecko default plugin)
DivX Web Player 1.4 (DivX Web Player version 1.4.0.233)
Flip4Mac Windows Media Plugin 2.2.3 (2.2.3.7)
iPhotoPhotocast 6.0
Java Embedding Plugin 0.9.7.1 (MRJ Plugin version 1.0-JEP-0.9.7.1)
QuickTime Plug-in 7.6.2
RealPlayer Plugin.plugin 0.0.1d1
Shockwave Flash 10.0.32.18
Shockwave for Director 11.0.0r429
Silverlight Plug-in 2.040115.0

Again, with the same results (error window as above in this bug, no Firefox start)

I have also tried with a minimal profile, including no extensions and with all the above plugins disabled. I'm happy to make the profile available as an attachment to this bug if it would help. Results are the same with this profile.

Results:

Irrespective of installed extensions and plugins, the results are as follows. Note that 1) "OK" means "a correctly started Firefox"; obviously functionality is degraded if plugins are disabled. 

2) "FAIL" means "Firefox started but only displayed an error window containing

XML Parsing Error: undefined entity
Location: chrome://browser/content/browser.xul
Line Number 36, Column 1:<window id="main-window"
^

3) I'm using about:config to change general.useragent.locale to the various locale settings. In the results below I'm abbreviating general.useragent.locale to "gul".


Irrespective of the profile used ("default", with extensions installed and plugins enabled, or "minimal", no extensions installed and all plugins disabled):

Safe mode start - OK

Non-safe mode start -

set gul to an invalid locale (bb-XX): OK
set gul to a valid but not installed locale (pt-BR): OK
set gul to en-US: OK
set gul to an en language, but not installed locale (en-IE): FAIL
set gul to an en language, invalid locale (en-XX): FAIL
set gul to an en language, valid and installed locale (en-GB): FAIL


Further information - the contents of  /Applications/Firefox.app/Contents/MacOS/chrome are as follows:

-rw-r--r--   1 tonyw  admin     1306 Jan 19  2009 en-GB.manifest
-rw-r--r--   1 tonyw  admin   477876 Jan 19  2009 en-GB.jar
-rw-r--r--   1 tonyw  admin      517 Jul  3 13:37 toolkit.manifest
-rw-r--r--   1 tonyw  admin      439 Jul  3 13:37 reporter.manifest
-rw-r--r--   1 tonyw  admin       69 Jul  3 13:37 pippki.manifest
-rw-r--r--   1 tonyw  admin     1251 Jul  3 13:37 en-US.manifest
-rw-r--r--   1 tonyw  admin      144 Jul  3 13:37 comm.manifest
-rw-r--r--   1 tonyw  admin      264 Jul  3 13:37 classic.manifest
-rw-r--r--   1 tonyw  admin     1143 Jul  3 13:37 browser.manifest
-rw-r--r--   1 tonyw  admin  1986515 Aug  4 23:47 toolkit.jar
-rw-r--r--   1 tonyw  admin    39459 Aug  4 23:47 reporter.jar
-rw-r--r--   1 tonyw  admin   279011 Aug  4 23:47 pippki.jar
-rw-r--r--   1 tonyw  admin   477417 Aug  4 23:47 en-US.jar
-rw-r--r--   1 tonyw  admin    40069 Aug  4 23:47 comm.jar
-rw-r--r--   1 tonyw  admin   888116 Aug  4 23:47 classic.jar
-rw-r--r--   1 tonyw  admin  2083931 Aug  4 23:47 browser.jar

Note that an older version of en-GB stuff exists.

Is it possible that the FF3.5 download has over-written the en-US portions but a previously-installed en-GB localised version has not been upgraded? I'd go ahead and install the 3.5.2 en-GB version as linked from http://www.mozilla.com/en-US/firefox/all.html but I can't see why this is affecting "en-XX where XX is anything other than US". I'd also be interested to know what general.useragent.locale Nikolay's using. I doubt it's en-GB!

Please advise as to what specific information you'd like me to provide.
Sorry for the delay. Can you please run another installation of Firefox 3.5? You can drop it to the desktop instead of the application folder. Running your steps from comment 13 result in the same behavior? Or does it work this time? If it fails you should archive the application bundle and send it to me. I can have a look at it.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is far gone. If the reporter can still see this issue, Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Then please remove the closeme tag in the whiteboard, mark the bug against the proper version and comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.