Run firefox with parameter in ASCII and special charater in link

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: LSI, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

I have external program to open webpage. link to webpage contain charaters é à ô for example.
if i do this windows API
shellexecute(0, 0, "http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder en icône/1.2", "", "", 0)
link don't work, charaters like ô is replaced by unicode ÂZ
but if i write this link in adress bar, all is ok.
i obtain
http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder%20en%20ic%F4ne/1.2
so why Firefox don't transform link in parameter like it transform when i write


Reproducible: Always

Steps to Reproduce:
1. do
shellexecute(0, 0, "http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder en icône/1.2", "", "", 0)
2. write in adress bar
http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder en icône/1.2
and press enter
3. have to be the same result in the both case
http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder%20en%20ic%F4ne/1.2
Actual Results:  
with 
shellexecute(0, 0, "http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder en icône/1.2", "", "", 0)
i have in adress bar
http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder en icône/1.2


Expected Results:  
adress must be transform in
http://www.lsi-dev.com/index.php?mod=checkupdate&check=Encoder%20en%20ic%F4ne/1.2
The adressbar fixes many different errors for the human like "c:" will be fixed to "file:///c:/" but everything that doesn't come from a human input will not be fixed and it's expected to get only valid URLs.

Why Firefox doesn't do this ?
Such illegal would be used everywhere if Firefox starts to accept this illegal URLs and that would lead to inconsistent behavior between different browsers.
marking invalid because this is no bug, it's by design.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.