Graphical interface problem - Memory related

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Gerardo Hdz., Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; es-ES; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

I run a lot of applications, for example:
 - Eclipse (IDE)
 - Apache Tomcat
 - DB2 9.5
 - DBVisualizer
 - Java applications
 - Microsoft Outlook
 - Sun IMQ
The memory usage of all this stuff is like 2.3 GB (My computer has 4GB RAM)
When i run Firefox 3.5 with all this stuff running, the visual controls (Browser toolbar buttons, tabs, etc) is displayed mmm how to say it... "in blank?" i mean, the has not the visual component, just like if an EMPTY theme was applied.
So, i think this is a memory problem. It's also important to say that this problem does not occur with Firefox 3.0.11, so i went back to this version.

Reproducible: Always

Steps to Reproduce:
1. Open a lot of programs (Eclipse, DB2, Tomcat, MS Outlook, DBVisualizer, Java apps, etc.)
2. Run Firefox.
Actual Results:  
Graphical interface without images on the buttons, tabs, etc... not only without images, but without the theme ... It's like applying an EMPTY Theme...

Expected Results:  
Regular Firefox behavior.

This problem occurs with any of the themes i have.
Addons: FoxyProxy, Personas, ABP, FireBug, FireFTP, IETab, FEBE, GooglePreview, GoogleRedesigned, ScrapBook, FireSizer, FoxMarks, Glasser, Local Install, ReadItLater, WebMail Notifier, etc.
IMPORTANT: This problem DOES NOT HAPPENS if i run Firefox 3.0.11.
So, it has to be a problem in Firefox 3.5.
Does it also happen in safe-mode? http://support.mozilla.com/en-US/kb/Safe+Mode
Version: unspecified → 3.5 Branch
(Reporter)

Comment 2

9 years ago
Certainly i don't know 'cause I didn't try using safe-mode (I didn't know this exist.)
As soon as i have a chance, i'll make a new test using FF 3.5 ('cause I went back to FF 3.0.11)

Thanks a lot for reading me. Regards from Monterrey, MEXICO.

Gerardo Hernández.
(Reporter)

Comment 3

9 years ago
I tested with safe-mode, and it works fine. I mean, the error is gone when i run Firefox in safe-mode.
(Reporter)

Comment 4

9 years ago
(In reply to comment #1)
> Does it also happen in safe-mode? http://support.mozilla.com/en-US/kb/Safe+Mode


I tested with safe-mode, and it works fine. I mean, the error is gone when i
run Firefox in safe-mode.
OK, then it seems like it is an extension or user made customization. Please disable your extensions one by one, and report the issue the the author of the one that caused it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

9 years ago
Ok, i did it, Safe-Mode, the error is there.
I have a screen shot... how can i attach it here ?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 7

9 years ago
Created attachment 388027 [details]
Screenshot of Firefox with the problem

Well, just a Screenshot of Firefox 3.5 running on Windows Vista, with the problem I reported. I like Firefox, and i'd like it running perfectly on my laptop, that's why I'm reporting this...
Regards.
Looks like an extension. create a new profile and see if it happens there.
(Reporter)

Comment 9

9 years ago
But it's running on Safe-Mode, all extensions are disabled.
A new profile is a more reliable way of checking if Safe mode does not work.
(Reporter)

Comment 11

9 years ago
I did it, i opened Firefox 3.5 using a new created profile, I still get the same problem. (See the attached screenshot).
Thanks in advance. Regards.
(Reporter)

Comment 12

9 years ago
Any comments on this ???
Still having the problem... :(
(Reporter)

Comment 13

9 years ago
I think i'll go back (again) to Firefox 3.0.11
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

9 years ago
It was fixed on version 3.5.2
Thanks a lot and Regards!
alright, well unless we know what exactly did it, wfm.
Resolution: FIXED → WORKSFORME
(Reporter)

Comment 16

9 years ago
"unless we know what exactly did it"?
What do you mean ?
If we know what exact patch fixed this, then we can mark fixed.
(Reporter)

Comment 18

9 years ago
I feel you don't believe there was a problem that was fixed on this new version.
Am I right ?
Resolution FIXED is reserved for bugs that had code applied to resolve the problem. So at least a bug number is needed.
And of course it is possible that a clean installation removed bad code placed there by other programs, that made Firefox malfunction.
(Reporter)

Comment 21

9 years ago
Bug number: 502328
And i didn't do a clean installation, i just upgraded from Firefox 3.5.1 (which was having the problem) to Firefox 3.5.2
But it's ok and Thanks any ways.
(In reply to comment #21)
> Bug number: 502328
The number of the bug that fixed it. Here is the archive if you want to search: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
> And i didn't do a clean installation, i just upgraded from Firefox 3.5.1 (which
> was having the problem) to Firefox 3.5.2
Is possible if is was not a partial update. Then the entire application is replaced.
(Reporter)

Comment 23

9 years ago
I think this bug has to be with mine because i have 4GB RAM installed on my Laptop (Thinkpad W500)
https://bugzilla.mozilla.org/show_bug.cgi?id=472097
Regards.
You need to log in before you can comment on or make changes to this bug.