Closed Bug 502452 Opened 12 years ago Closed 12 years ago

drag and drop of a tab should add a new tab when control key is pressed

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 470189

People

(Reporter: laterality, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

Firefox correctly shows '+' drag feedback when control key is pressed, but the bug is that it still replaces the currently displayed tab.

The desired behaviour when the control key is pressed is:
- when the cursor (drop site) is over the tab content, add to rightmost end of tab bar 
- when the drop site is a tab thumb in the tar bar, add to right of the tab under cursor


Reproducible: Always

Steps to Reproduce:
1. With tabbed browsing enabled, open two Firefox windows 
2. Start dragging a tab from one (source) window to the second (target) window, and press Control key
3. Drop the tab on the browser content pane

Actual Results:  
The tab switches to the dropped URL 

Expected Results:  
The tab is added to the rightmost end.

The workaround is to move the cursor to the tab bar until the drop site is "between" two tabs; this is however much less convenient because it provides a drop site of only a few pixels, whereas the browser content pane is at least 800x600 pixels on a modern display.
Can you try this in 3.5?  If I understand what you're saying, the behavior is how you want it in 3.5.
Thanks for responding so fast!

Firefox 3.5 behaves *very* differently, with pros and cons (new bugs):
+ Drag indicator now shows a preview of the tab you're dragging - very nice!
- dragging onto another window without using Control key will open the tab in a new window; if the tab is already opened in a separate window, dragging does nothing with no drag feedback to indicate that this is an unsupported operation
- there is no way at all to drag the tab onto an existing window

The test cases I suggest that tab drag and drop should support are at least:
- drag onto desktop (create new window)
- drag onto desktop with control pressed (create *copy*of new window, leaving tab with its history in the original window)
- drag onto tab bar of same window (move)
- drag onto another window:
 -> onto browser pane; *move* and replace active tab
 -> onto browser tab; *move* and replace that tab
 -> between browser tabs; *move* and insert between those tabs
 -> with Control pressed; do as per respective action, but *copy* the tab without history, and leave tab with its history in the original window

And thanks for Firefox, far and away the best browser!
 (In reply to comment #2)
> Thanks for responding so fast!

No problem :-)

> 
> Firefox 3.5 behaves *very* differently, with pros and cons (new bugs):
> + Drag indicator now shows a preview of the tab you're dragging - very nice!
> - dragging onto another window without using Control key will open the tab in a
> new window; if the tab is already opened in a separate window, dragging does
> nothing with no drag feedback to indicate that this is an unsupported operation
> - there is no way at all to drag the tab onto an existing window
> 

Yep, you can drag a tab to an existing window if you drag it to the tab bar.

> The test cases I suggest that tab drag and drop should support are at least:

Going through these one by one

> - drag onto desktop (create new window)

Is the current behavior (as far as I can tell, if not, we need to reopen bug 475066 )

> - drag onto desktop with control pressed (create *copy*of new window, leaving
> tab with its history in the original window)

Don't think we do anything like this.

> - drag onto tab bar of same window (move)

We do that.

> - drag onto another window:
>  -> onto browser pane; *move* and replace active tab

This we don't do.  Bug 470189.

>  -> onto browser tab; *move* and replace that tab

If by replace you mean focus to the new tab we do that.  If by replace you mean overwrite the existing tab, we don't do that because it's difficult to hit exactly between two tabs.

>  -> between browser tabs; *move* and insert between those tabs
We do that.
>  -> with Control pressed; do as per respective action, but *copy* the tab
> without history, and leave tab with its history in the original window

We do this, but we take history with us.  Is there a compelling reason not to take history?

> 
> And thanks for Firefox, far and away the best browser!

Glad to hear it.

It seems as though there are three issues you've raised.  Bug 470189, the fact that tearing a tab off to the desktop does not obey the control key, which is IMO a bug, and the fact that while pressing control the history is taken with the tab, which I'm not sure is incorrect behavior.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470189
You need to log in before you can comment on or make changes to this bug.