Crash [@XPCNativeWrapper::GetNewOrUsed] with Adblock Plus 1.1 installed

VERIFIED FIXED

Status

()

defect
--
critical
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: gaubugzilla, Assigned: mrbkap)

Tracking

(4 keywords)

1.9.0 Branch
x86
Windows XP
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.0.12 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Firefox 3.0.12 nightlies crash reproducibly on startup if the current Adblock Plus 1.1 development build is installed (https://adblockplus.org/devbuilds/). Crash reports:

http://crash-stats.mozilla.com/report/index/4bba2fe6-c281-423e-87c4-7ab7f2090705
http://crash-stats.mozilla.com/report/index/f19ba8d9-5446-40d8-9963-63ac02090705
http://crash-stats.mozilla.com/report/index/58171c91-7550-4055-b38e-ecb922090705

Firefox 3.0.11 doesn't exhibit this behavior. Looking at the recent changes, this is likely fallout from bug 460882 (which I cannot link to). Given that Adblock Plus 1.1 is supposed to be released in about a week, requesting blocking-1.9.0.12.
Flags: blocking1.9.0.12?
Blake: Can you take a look at this ASAP? If it's a regression in this cycle, we probably need to fix it now. We were hoping to hand off to build in ~9 hours though...
Assignee: general → mrbkap
Wladimir: Bug 460882 landed the evening of June 23 -- do you see this regress between the nightlies of 20090623 and 20090624?
This "regressed" as a result of bug 460882 landing on the 1.9.0 branch. It only regressed because bug 455633 hasn't landed on that branch. I can backport that fix if you want...
Blocks: 460882
Depends on: 455633
Flags: blocking1.9.0.12? → blocking1.9.0.12+
The fix for bug 455633 should fix this everywhere. Wladimir, please test with tomorrow's nightly!
Keywords: fixed1.9.0.12
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
The nightly isn't out yet so I tested the hourly builds - 1246856700 (05-Jul-2009 23:32) still crashes while 1246861980 (06-Jul-2009 00:53) doesn't. Thanks, seems to be fixed!
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.12pre) Gecko/2009070606 GranParadiso/3.0.12pre (.NET CLR 3.5.30729).
Status: RESOLVED → VERIFIED
Crash Signature: [@XPCNativeWrapper::GetNewOrUsed]
You need to log in before you can comment on or make changes to this bug.