Firefox 3.5 doesn't remember privacy settings

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: marti, Unassigned)

Tracking

3.5 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1) Gecko/20090705 Gentoo Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1) Gecko/20090705 Gentoo Firefox/3.5

Might be related to the Firefox 3.0 bugs: bug 440865, bug 453719.


Reproducible: Always

Steps to Reproduce:
1. Open Edit -> Preferences dialog
2. Change some privacy preferences and click 'Close'
3. Open preferences again
Actual Results:  
All the settings have reverted back to what they were before.


This occurs on a pretty clean profile. I wiped out my profile and created a new one with Firefox 3 yesterday. After creating the new profile and installing a couple of extensions, I upgraded to Firefox 3.5 beta. This has been happening ever since. I can't change privacy preferences, delete cookies, etc. The changes seem to take effect at first, but after closing and re-opening the window, everything's back to how it was.
(Reporter)

Comment 2

9 years ago
I read the link in comment #1, but it didn't help me.

Note that this isn't only about prefs.js because I cannot delete my cookies either. When I click "Remove All Cookies", it seems to change something, but when I open the cookies dialog again, it's back to what it was.

On the other hand, settings in other tabs (like Security) work. Deleting saved passwords works.

Also:
1) I have no User.js file in my Firefox profile directory.

2) I'm fairly sure that my Firefox preferences files are not locked. I tarred up the profile, deleted the directory, and created it again:
cd ~/.mozilla/firefox; tar czf normal.tar.gz normal; rm -rf normal; tar xzf normal.tar.gz

I still have the same problem. I'm running Firefox under the same user that has access to untar those files. I don't have any funky security modules installed either.

3) The prefs.js file doesn't look corrupted to me, and Firefox is successfully writing to it.

% stat prefs.js
  File: `prefs.js'
  Size: 16207     	Blocks: 32         IO Block: 4096   regular file
Device: fe08h/65032d	Inode: 1418743     Links: 1
Access: (0644/-rw-r--r--)  Uid: ( 1000/   marti)   Gid: (  407/   marti)
Access: 2009-07-06 01:43:51.000000000 +0300
Modify: 2009-07-06 01:43:51.000000000 +0300
Change: 2009-07-06 01:43:51.000000000 +0300
% firefox
[after quitting Firefox]
% stat prefs.js
[...]
Modify: 2009-07-06 01:44:12.000000000 +0300
Change: 2009-07-06 01:44:12.000000000 +0300

Comment 3

9 years ago
Seems to work - changing a preference sticks within a session (in this case I set history to 999 days) it was still visible at that setting when opened again, and after browser was closed and reopened.

Comment 4

9 years ago
Same exact problem here. I reinstalled with a fresh download, same issue.  

Reproducible: Always

Steps to Reproduce:
1. Open Edit -> Preferences dialog
2. Change some privacy preferences and click 'Close'
3. Open preferences again
Actual Results:  
All the settings have reverted back to what they were before.

Comment 5

3 years ago
Does this still happen with the new in-content preferences?
Flags: needinfo?(marti)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Flags: needinfo?(marti)
You need to log in before you can comment on or make changes to this bug.