Weave syncs very slowly and slows down the browser

RESOLVED FIXED

Status

Cloud Services
Firefox Sync: Backend
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Sebastian Wiesinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5
Build Identifier: Weave 0.4.0

I'm using Weave for a few days now. Everything was fine, but an hour ago Weave started to sync very very slowly, taking almost a minute to sync. While it is syncing the browser is very unresponsive.

Looking in the logfile it seems like it is syncing the same bookmarks over and over again, see attached logfiles.


Reproducible: Always

Steps to Reproduce:
1. Start Sync
2.
3.
Actual Results:  
Sync takes almost one minute and makes the browser unresponsive.

Expected Results:  
Sync should finish much faster.
(Reporter)

Comment 1

9 years ago
Created attachment 386893 [details]
Weave Log
(Reporter)

Comment 2

9 years ago
I just fixed the problem by adding a bookmark and syncing again... Don't know how to reproduce it. :(

Comment 3

9 years ago
This was a server problem, it was incorrectly rounding down timestamps, causing the client to request the same set of changes over and over again.

We fixed this last night, so it should not happen again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

9 years ago
Hi,

is this fix already available in the hg repository for weaveserver? Because I'm using my own server. I checked out the newest build but can't find the change.

Comment 5

9 years ago
What version of php is your server running?
(Reporter)

Comment 6

9 years ago
PHP 5.2.8 with XCache

Comment 7

9 years ago
Sebastian, you should be fine with that set-up. There were no actual Weave Server code changes. Try running the test php code in bug 502734 comment 0 just to double check.
(Reporter)

Comment 8

9 years ago
The code worked fine, as expected with my PHP version. Perhaps my bug was something different after all because I didn't change my PHP. It was 5.2.8 when I encountered the bug. But even then I can't reproduce it at the moment. :(
You need to log in before you can comment on or make changes to this bug.