update failed and cannot run any version of thunderbird

RESOLVED DUPLICATE of bug 452162

Status

Thunderbird
Installer
--
critical
RESOLVED DUPLICATE of bug 452162
9 years ago
9 years ago

People

(Reporter: John Stoops, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17
Build Identifier: 

The automatic update to Thunderbird to xxxx.22 crashed and left a corrupt system.  I cannot delete the partial file nor can I successfully install the new version.  It happened this morning - any tips for how to proceed?

Reproducible: Always
(Reporter)

Comment 1

9 years ago
2.0.0.22 failed to install and run
the partial overwrite of 2.0.0.21 corrupted it and it will not run
Severity: normal → critical
Component: General → Installer
Version: unspecified → Trunk
What do you mean with crash ?
A real crash or an error message about a file in use ?

>I cannot delete the partial file
What partial file, that one from the update ?

>nor can I successfully install the new version
why not ?
(Reporter)

Comment 3

9 years ago
> What do you mean with crash ?
> A real crash or an error message about a file in use ?
>   
Complete non-function.  The Thunderbird program has been replaced by a non-recognized file and I can do nothing with it.  My computer functions but Thunderbird is no longer an executable file.
>   
>> I cannot delete the partial file
>>     
> What partial file, that one from the update ?
>   
I go to control panel to remove the program and the remove button does not function - I click and nothing happens - the shortcut has been replaced by a non recognized file.  I had to revert to SeaMonkey for mail which seems to work but the archives for the last couple of years from Thunderbird are not visible.
>   
>> nor can I successfully install the new version
>>     
> why not ?
>
>   
I download and it hangs on a partial install - I'll try again try to capture the error message: Error opening file for writing.  C:\Program Files\Mozilla Thunderbird\MozMap32.dll  ...  delete\cancel etc ....
You have the mozmapi file in use error message.
If you use the logitech quickcam software close the process in the taskmanager.
Software like this one opens a file (always!) from Thunderbird and the Updater can not write it.

If you can not find the the process that is doing that you can start windows in the windows safemode and install Thunderbird in that safemode, that should work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 452162
(Reporter)

Comment 5

9 years ago
THANK YOU!  That fixed it.
You need to log in before you can comment on or make changes to this bug.