scratchbox is broken on linux staging slaves

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: nthomas, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Trying to run '/scratchbox/moz_scratchbox' on these machines dies with
  /scratchbox/moz_scratchbox: line 11: /scratchbox/login: Permission denied
  program finished with exit code 126
which is kinda fatal when trying to compile. Note that a separate error on moz2-linux-slave17 with the m-c checkout was breaking "Maemo mozilla-central l10n" should be fixed now that I nuked that dir. And Maemo mozilla-1.9.1 is busted without l10n.mk.

Looks like fallout from Puppet based on bug 486614 comment #6 and when Maemo mozilla-central build stopped working:
# (Jun 24 12:44) rev=[??] failure Maemo mozilla-central build #210: failed compile
# (Jun 24 09:47) rev=[??] success Maemo mozilla-central build #209: build successful
(Assignee)

Comment 1

9 years ago
D'oh. This is my fault. I'll fix it.
Assignee: nobody → bhearsum
(Assignee)

Comment 2

9 years ago
By the way, I've commented scratchbox out of the checks in both staging and production puppet setups until we ensure it's working.
(Assignee)

Comment 3

9 years ago
It looks like this was actually caused by a GID change when I deployed Puppet. 501 used to be sbox, now it is puppet. Because /scratchbox/login is 754, that broke things. Unfortunately, I already began the process of reinstalling scratchbox when I noticed this.

The production builds are also affected, but because none of their Buildbot processes have restarted they continue to work. I'll fix those up along with the staging installations.
(Assignee)

Comment 4

9 years ago
OK - I fixed up /etc/group on everything via puppet, and fixed up the scratchbox installs on the staging machines. We should be 100% fine here going forward.

I'll check in on them tomorrow to double check.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
No longer blocks: 486614
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.