bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Shutdown fails with 100% cpu load when auto-complete over LDAP is used

RESOLVED DUPLICATE of bug 420744

Status

MailNews Core
Address Book
--
critical
RESOLVED DUPLICATE of bug 420744
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({hang})

1.9.1 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.1pre) Gecko/20090705 Shredder/3.0b3pre ID:20090705024443

Since a couple of days I have noticed that when trying to upgrade Shredder the shutdown doesn't work. It hangs and the following alert is shown:

"The operation cannot be completed because of an internal failure. A secure network connection has not been cleaned up correctly."

Eventually this has been started since I have been using my StartCom free SMIME certificate.
Flags: blocking-thunderbird3?

Comment 1

9 years ago
Are you using an SSL LDAP server and doing auto-complete against it? This sounds like a dup of the bug where we don't always clean up ldap connections. Or could it be the ssl update connection isn't cleaned up?
Yes, I'm using the Mozilla LDAP server with auto-complete turned on. I haven't seen it the last time though.

Updated

9 years ago
Whiteboard: [need more info]

Comment 3

9 years ago
If you shutdown immediately after sending a message with auto-complete, you can encounter a known bug where we haven't cleaned up our ssl ldap connection before shutdown happens. Is it possible this is what happened to you? I can't find the bug right now, but if so, it would be a dup of that bug, and not a blocker.
Yeah. That's it. When you find the bug feel free to dupe. Thanks David.
It's definitely auto-complete. When I use an already sent email and send it again without using auto-complete the application shutdown without any problem. Only when using auto-complete which is a LDAP connection for mozilla.org causes this hang. If no other bug is open we should track the issue here.
Summary: Shutdown failed due to a security network communication which hasn't been cleaned up correctly → Shutdown fails with 100% cpu load when auto-complete over LDAP is used

Comment 7

9 years ago
I'm sure we had a bug on this - I don't know if it was marked fixed or not. We did make several fixes for leaks of ldap connections, but this is more of a shutdown race, caused by difficulties in cleaning up the ldap connections.

Comment 8

9 years ago
(In reply to comment #7)
> I'm sure we had a bug on this - I don't know if it was marked fixed or not. We
> did make several fixes for leaks of ldap connections, but this is more of a
> shutdown race, caused by difficulties in cleaning up the ldap connections.

yeah, I forgot to comment/agree that we had seen this in the past, and jives with a bug comment of mine implicating compose/autocomplete which I can't find (bonus if you find it).  Am having @)#$(* trouble finding it because it probably doesn't have ldap in the summary or component :)  I don't know if this list nails it but here's what I come up with ...

open Bug 420744 thunderbird hangs on shutdown 
INCO bug 482094 Thunderbird failing to close properly  (which I recently closed - no opinion on whether we should reopen)

recent FIXED bugs include
 Bug 382446 -  Alert on shutdown when using ldaps address book - "operation can not be completed because of an internal failure. A secure network communication has not been cleaned up correctly."
 Bug 396364 -  Address Book fails to shut down correctly if LDAP password dialog is cancelled

there's Bug 494014 - shutdown hang, high cpu, no open imap connections - but iirc that's not ldap related

There are open and incomplete shutdown bugs which are not well defined, eg bug 482094.

xref last comments in FIXED bug 487965 - hang on shutdown with open imap connections and zero cpu

Comment 9

9 years ago
bug 382446 was the one I was thinking of - it was marked fixed because the main connection leak was fixed, but afterwards, we discovered that there's still a connection left open if you shut down immediately after sending a message. I think this bug can stand for the remaining issue, because I can't find a bug that describes the issue - davida ran into it, and we (Standard8 and I) debugged it, but I don't know if the info ended up in a bug.

Comment 10

9 years ago
OK found my comment - bug 420744 comment 2 and comment 5 and stephend's  bug 420744 comment 6 (I was an idiot for not putting ldap in the summary)

duping to bug 420744 which has several ppl already cc on the issue
Severity: major → critical
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Component: Security: S/MIME → Address Book
QA Contact: s.mime → address-book
Resolution: --- → DUPLICATE
Whiteboard: [need more info]
Duplicate of bug: 420744

Updated

9 years ago
Flags: blocking-thunderbird3?
You need to log in before you can comment on or make changes to this bug.