Firefox cache not cleared even after clearing the cache

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Athi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-12-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729)

Hi,
    First of all thank you for looking into my case.

Please see the following url, to get to know about my problem.
http://forums.mozillazine.org/viewtopic.php?f=38&t=775945&start=0&st=0&sk=t&sd=a

I dont know why the problem exists in our environment. How far is the possibility for a "bad" code can be reason behind it? Or, is it 'coz of Firebug?

Reproducible: Always




I am launching a child screen, from a parent screen. If the child screen has some error(in the script) and I go back to the parentscreen, and then on coming back to the child screen(by using a link in the parent screen), the cache doesnt get cleared. But, while I am in the parent screen, if I come back to the child screen, after pressing F5 in the parent screen, the cache is clearing properly. (This scenario is simulatable only in our application. The test pages I wrote work fine)
What do you mean by "child screen"? A new tab, window, pop-up and how do you launch it? With a context menu option? 
Also, can you update to the latest release? It has the latest fixes.
http://www.mozilla.com/en-US/
(Reporter)

Comment 2

9 years ago
Child Screen: A link(anchor) to another screen, which is launching in the same window only.

Yes.. I am having the latest 3.0 version. Latest build.

To give you some more details, when the bug comes, the code breaks @ particular location. Say objControl.attachEvent(..);. If I press F8(in firebug) and on pressing SHIFT+CTRL+R, "without moving the mouse", its getting updated with the new file. Our application has events for mouseover, bodyfocus, etc. So, I doubt, whether that is the problem.

Comment 3

9 years ago
(In reply to comment #2)
> Yes.. I am having the latest 3.0 version. Latest build.

Firefox 3.5 is the latest version.
(Reporter)

Comment 4

9 years ago
hmm... Fine.. I installed 3.5 too and checked. Its all the same. I think, it is 'coz of Firebug plugin. 'coz the other profile, which doesnt have Firebug, is working fine. Only the default profile is giving the problem. Please confirm.
(Reporter)

Comment 5

9 years ago
Is there any update? Is my assumption correct? Or, is there any issues with the default profile? Why I asking this is, even after removing firebug(not disabled, but fully removed), its not working in the default profile itself.

Comment 6

9 years ago
I've had this happen to me as well. Only started happening since upgrade to 3.5.1

Steps to reproduce.  I have Firebug installed but disabled. Not sure if that is sufficient. 

1. Visit http://www.strawberrynet.com/cologne/. You might need to clear cache and refresh once or twice to "prime" things as I've not done this from a virgin install
2. Clear your cache. (Clear Recent history + Everything + cache box checked only)
3. Reload the page
4. Check about:cache
5. What's visible is that the all images under /left_main/* are not showing in the cache. Also, using a HTTP trace tool like Charles they do not show up as being loaded from the website.
6. Clear the cache again and restart the browser
7. Revisit the site and confirm that images from /left_main/* are loaded this time

Note this *may* be related to the Content-Length as interpreted by the browser. Manually loading an image from /(left_main/* in to cache shows it to be 0 bytes which is untrue

e.g.
GET /left_main/m.gif HTTP/1.1
Host: www.strawberrynet.com
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.1) Gecko/20090715 Firefox/3.5.1 (.NET CLR 3.5.30729)
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-gb,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7

Response:
HTTP/1.1 200 OK
Content-Length: 220
Content-Type: image/gif
Last-Modified: Wed, 15 Apr 2009 07:52:00 GMT
Accept-Ranges: bytes
ETag: "050a6e9fbdc91:195e"
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Cache-Control: max-age=3600
Date: Fri, 24 Jul 2009 07:03:29 GMT


HTTP/1.1 200 OK
Content-Length: 220
Content-Type: image/gif
Last-Modified: Wed, 15 Apr 2009 07:52:00 GMT
Accept-Ranges: bytes
ETag: "050a6e9fbdc91:195e"
Server: Microsoft-IIS/6.0
X-Powered-By: ASP.NET
Cache-Control: max-age=3600
Date: Fri, 24 Jul 2009 07:03:29 GMT

About:cache
Key: http://www.strawberrynet.com/left_main/m.gif
Data size: 0 bytes
Fetch count: 1
Last modified: 2009-07-24 17:03:29
Expires: 2009-07-24 18:03:29

Comment 7

9 years ago
Bug 487883 indicates a simialr issue as I've described above.

Comment 8

8 years ago
Version 3.5.7 not an issue on my Laptop that is running Vista PRO but is an issue on my home PC which has vista home edition. Both are Dell Dual core machines.
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc/) Go to the developer's website and download the latest version from there.
Whiteboard: [CLOSEME 2010-12-01]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 11

7 years ago
Hi,

    Ya.. now its working fine for me. Thank you all for your efforts.

Really sorry for the late reply.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.