Singular anchor tag interpreted as surounding the following sections

RESOLVED DUPLICATE of bug 162653

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 162653
9 years ago
9 years ago

People

(Reporter: lijat.me, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/531.0 (KHTML, like Gecko) Chrome/3.0.183.1 Safari/531.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

When writing two singular anchor tags after each other the second anchor tag is interpreted as surrounding sections following it. 

Example
<h4>
      <a name="SECTION00022100000000000000"/><a name="Cirkel_radie"/> <br/> <span class="arabic">1</span>.<span class="arabic">2</span>.<span class="arabic">1</span> Cirkel radie
    </h4>

is interpreted as 

<h4>
<a name="SECTION00022100000000000000"/>
<a name="Cirkel_radie">
<br/>
<span class="arabic">1</span>
.
<span class="arabic">2</span>
.
<span class="arabic">1</span>
Cirkel radie
</a>
</h4>

The later is copied from firebug,

Also sections following the closing </h4> tag is interpreted as being surounded by copies of the later <a name="foo"/> tag

Reproducible: Always

Steps to Reproduce:
1. Visit the url provided and watch the javascript output or firebugs interpretation of the tags, its reproducible with and without javascript enabled

Actual Results:  
Incorect xml tree visible to javascript causing correct javascript to produce garbage in garbage out

Expected Results:  
No visible <a> html tag in the javascript output on the page

<a name="foo"/> beeing equivalent to <a name="foo"></a>

if changing to <a name="foo"></a> the problem dissapears
(Reporter)

Comment 1

9 years ago
Created attachment 386968 [details]
archive of files demonstrating the problem
(Reporter)

Comment 2

9 years ago
Maybe should note that when testing with other gecko based browsers the same problem occurs so its not version or firefox specific
According to the XHTML 1.0 specification section C.3 of appendix C, you may not use of <a /> within html.

If you want us to parse your XHTML as XML, please give it the correct MIME type
(text/xml or application/xhtml+xml).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 162653
You need to log in before you can comment on or make changes to this bug.