Closed Bug 502629 Opened 15 years ago Closed 13 years ago

Moving messages from virtual folder spanning accounts misses state change (mark deleted)

Categories

(Thunderbird :: Folder and Message Lists, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INCOMPLETE

People

(Reporter: mozilla-bugzilla, Unassigned)

References

Details

(Whiteboard: [closeme 2011-05-01])

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.1) Gecko/20090630 Fedora/3.5-1.fc11 Firefox/3.5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.1pre) Gecko/20090706 Lightning/1.0pre Shredder/3.0b3pre

TB built from d63cdec41f66.

Thunderbird loses messages when I move multiple messages (multi-selection) from a virtual folder which spans several IMAP accounts to a proper IMAP folder.

Reproducible: Always

Steps to Reproduce:
1. Create virtual folder which spans several accounts (e.g. multiple Inboxes)
2. Select multiple messages in the virtual folder
3. Move those message to a different IMAP folder (proper folder)
Actual Results:  
Some messages get moved, but others get are lost: They are removed from the virtual folder (and their actual location) but do not appear at the destination folder.

Expected Results:  
All messages are moved to the destination, i.e.: copied to the destination and deleted at the source.

My virtual folder spans the Inboxes of several IMAP accounts, including gmail and a proprietary server (ComminugatePro) which has the "Move" extension to IMAP. The destination folder (proper folder) is on the CP server. Both the virtual folder and the destination folder a subfolders of the root of that same account (i.e. on the same level as Inbox, Sent etc.).

My suspicion is that the "copy notifications" from the various servers get intermixed and some messages get deleted before they have been copied. Systematic testing and with varying source and destination is a pain but I will try.
Since you seem to have a build environment available, I would be very interested if the patch from bug 497622 solves the problem that you have reported.

Any chance that you could apply it and report back?

The current patch has bit-rotted slightly, but it is just a change to the UUID of an interface that is failing, so you could probably just ignore that error.
(In reply to comment #1)
> Since you seem to have a build environment available, I would be very
> interested if the patch from bug 497622 solves the problem that you have
> reported.
> 
> Any chance that you could apply it and report back?
> 
> The current patch has bit-rotted slightly, but it is just a change to the UUID
> of an interface that is failing, so you could probably just ignore that error.

I'm happy to report that patch d from bug 497622 improves things considerably! I applied the patch to the d63cdec41f66 tree and rebuilt. In the same scenario as reported originally (same accounts and folders involved), I moved 21 messages and all of them ended up correctly in the destination folder. No more data loss!

At first it looked as if 2 messages were copied to the destination but not removed from the source (still showing up in the virtual folder). It turned out they were sitting in the same account which has "only mark as deleted" configured, and after refreshing the virtual folder they showed up as deleted (before they showed up as normal). It's a virtual folder with "search online". I thought it should get notified of a state change, but that's a minor issue.

I'll keep that patch applied when I hg up next time. But, given that it fixes a data loss bug, I'd suggest applying to comm-central asap and cleaning up later if necessary.
Thanks for testing that. Your scenario was not one that I was aware of as another consequence of the problems fixed in bug 497622, but the problems are fairly generic so I'm not surprised that they occurred in other contexts.

Bug 497622 should land soon, and should be in TB 3 beta 3.

I'm going to dup this bug, but feel free to undup if you feel there are aspects remaining here beyond those addressed in bug 497622.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
(In reply to comment #3)
> Thanks for testing that. Your scenario was not one that I was aware of as
> another consequence of the problems fixed in bug 497622, but the problems are
> fairly generic so I'm not surprised that they occurred in other contexts.
> 
> Bug 497622 should land soon, and should be in TB 3 beta 3.
> 
> I'm going to dup this bug, but feel free to undup if you feel there are aspects
> remaining here beyond those addressed in bug 497622.
> 
> *** This bug has been marked as a duplicate of bug 497622 ***

Well, I'm not sure about the issue of the virtual folder ("search online" mode) missing the state change of messages which get marked deleted as a result of being moved away. If I move 1 message or even several messages from the same account out of that virtual folder then they get marked deleted immediately. If the virtual folder spans several accounts they are not marked deleted.

I guess that would suggest unduping but lowering the severity?
OK, I've unduped, and used "depends on" to clarify the relationship. You will need to clarify the summary when you are clear about the remaining problems.
Status: RESOLVED → UNCONFIRMED
Depends on: 497622
Resolution: DUPLICATE → ---
Changed severity and summary to account for the state after applying patch d from bug 497622.
Severity: critical → normal
Summary: Moving messages from virtual folder spanning accounts loses messages → Moving messages from virtual folder spanning accounts misses state change (mark deleted)
M.J.G.  If this problem didn't occur in version 2, you can add regression to keywords
Component: General → Folder and Message Lists
QA Contact: general → folders-message-lists
Version: unspecified → 3.0
(In reply to comment #7)
> M.J.G.  If this problem didn't occur in version 2, you can add regression to
> keywords

I don't remember whether this worked in TB 2, or whether I have even tried. The issue is still in Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6pre) Gecko/20091116 Lightning/1.0pre Shredder/3.0.1pre. In fact, one message was copied instead moved out of an account with "delete immediately" set.

But, no data loss here, rather the opposite. Also, the setup with a virtual folder spanning multiple accounts with different options is not that common, and I guess I'm not the only one using gloda rather than virtual folders these days.

Still, this is confirmed again by me, though I'm still the only reporter, which is why I'm not setting the bug to CONFIRMED.
M.J.G. 
do you still see this with version 3.1?
Whiteboard: [closeme 2011-05-01]
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago13 years ago
Resolution: --- → INCOMPLETE
(In reply to comment #10)
> RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel
> this change was made in error, please respond to this bug with your reasons
> why.

Sorry for the delay, but I had reported the original data loss problem as resolved in 2009 already.

About the missed "deleted" info: I see this even with a single e-mail in a virtual folder spanning accounts when I remove (detach or delete) an attachment - the e-mail appears twice (the original plus the changed one). When in a folder of that account directly it works.

Whether that is related or not I don't know.
You need to log in before you can comment on or make changes to this bug.