Firefox quietly allows an extension to be installed if already installed

REOPENED
Unassigned

Status

()

Toolkit
Add-ons Manager
--
enhancement
REOPENED
9 years ago
6 years ago

People

(Reporter: David Delony, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20111202], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090706 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090706 Minefield/3.6a1pre

Firefox will allow an extension to be installed even if it is already installed and the extension has not been updated.

Reproducible: Always

Steps to Reproduce:
1. Find an extension in Tools -> Add-ons
2. Find it on addons.mozilla.org
3. Click "Add to Firefox"
Actual Results:  
Firefox will install the extension, giving no indication that the extension is already installed or that the extension is the same version previously installed.

Expected Results:  
Firefox should display a confirmation saying something like "This extension is already installed. Do you want to continue?"

Comment 1

9 years ago
Kind of related to bug 275054, not sure if it is a dupe or not?
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Whiteboard: dupeme?

Updated

9 years ago
Version: unspecified → 1.9.1 Branch

Comment 2

9 years ago
Not a dup at all, and almost entirely unrelated.
Essentially bug 301191
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 301191

Comment 4

6 years ago
I think this is not exactly a duplicate. The user might want to know even if the installed extension is of the same version, so no reinstallation may be needed.
Status: RESOLVED → REOPENED
Depends on: 301191
Ever confirmed: true
OS: Mac OS X → All
Resolution: DUPLICATE → ---
Whiteboard: dupeme?
Version: 1.9.1 Branch → Trunk

Updated

6 years ago
Whiteboard: [testday-20111202]

Updated

6 years ago
Summary: Firefox allows an extension to be installed if already installed → Firefox quietly allows an extension to be installed if already installed
You need to log in before you can comment on or make changes to this bug.