Counter links on about:me Dont work

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: tchung, Assigned: Margaret)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [about:me])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090706 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090706 Minefield/3.6a1pre

The counter links on the "Hourly Browsing Activity" do not work.  Nothing opens, and an error is fired:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [mozIStorageStatement.getParameterIndex]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://aboutme/content/aboutMe.js :: processQuery :: line 621"  data: no]

Reproducible: Always

Steps to Reproduce:
1. install about:me extension
2. open error console
3. click on any of the counter links on Hourly Browsing Activity
Actual Results:  
no links open

Expected Results:  
links open
(Reporter)

Updated

9 years ago
Blocks: 480154
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [about:me]
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Actually, this applies to all counter links within the page, not just the top.
Summary: Counter links on Hourly Browsing Activity Dont work → Counter links on about:me Dont work
(Assignee)

Comment 2

9 years ago
It works in 3.5. I think this is a problem with Minefield because I'm using jQuery, which most likely isn't tested in Minefield.
Assignee: nobody → mleibovic
(Assignee)

Comment 3

9 years ago
The problem was with a change in the mozIStorageStatement API, but it's fixed now. about:me will still work with 3.5, but now will also work with minefield.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Any idea what patch may have fixed it?
You need to log in before you can comment on or make changes to this bug.