Images should stop animating after they're not referenced by a page

RESOLVED DUPLICATE of bug 359608

Status

()

Core
ImageLib
RESOLVED DUPLICATE of bug 359608
9 years ago
6 years ago

People

(Reporter: jrmuizel, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(blocking2.0 -, status2.0 wanted)

Details

Comment hidden (empty)
I was about to write a patch for this when it looks like we already (at least try to) do this:
http://mxr.mozilla.org/mozilla-central/source/modules/libpr0n/src/imgRequest.cpp#200

What consumers think of as an imgIRequest is actually an imgRequestProxy - a lightweight handle to a shared imgRequest behind the scenes. When the last handle goes away, the above code _should_ fire and stop animation. 

In general it looks like things are kind of broken with starting and stopping animation, because we don't make any distinction between an animation being stopped because we don't have enough frames to animate and being stopped because somebody wants us to be stopped. So if, for example, we remove the proxy before the second frame is decoded, the StartAnimation that fires on frame #2 decode will undo the work done by the StopAnimation in RemoveProxy. Definitely needs fixing, but not sure if that's the issue at work here.

Jeff says he's going to dial down the repro case and post it on the bug. Waiting for that.

Updated

8 years ago
blocking2.0: --- → ?
status2.0: --- → ?
blocking2.0: ? → -
status2.0: ? → wanted

Updated

7 years ago
QA Contact: imagelib → jmuizelaar
(Reporter)

Comment 2

6 years ago
I haven't seen this lately.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
QA Contact: jmuizelaar → imagelib
Resolution: --- → INVALID
More specifically, I  think this was fixed by bug 359608.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 359608
You need to log in before you can comment on or make changes to this bug.