[MLK] Leaking nsFileSpec objects

VERIFIED FIXED in M18

Status

SeaMonkey
MailNews: Address Book & Contacts
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Patrick C. Beard, Assigned: chuang)

Tracking

({memory-leak})

Trunk
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-][cut 8/28])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Forgetting to delete them after use. Enclosing two patches to fix.
(Reporter)

Comment 1

18 years ago
Created attachment 13476 [details] [diff] [review]
Patches to fix nsFileSpec leaks.
(Reporter)

Updated

18 years ago
Keywords: mlk, nsbeta3

Comment 2

18 years ago
reassigning to chuang.
Assignee: putterman → chuang
Keywords: patch
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 3

18 years ago
+, P3 per mail triage.
candice - pls review and check in the patch.
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 4

18 years ago
second pass: - per mail triage.  If there is a patch, we can check in, but not 
holding beta3 for this bug.
Whiteboard: [nsbeta3+] → [nsbeta3-][cut 8/28]
(Assignee)

Comment 5

18 years ago
I have reviewed the patch (two line change) and ready to check in this week with 
other memory leak bug (50351).  Can we make it nsbeta3+?

Comment 6

18 years ago
Candice, if there is a patch, you don't need nsbeta3+ to checkin, I believe.  I
think waterson or brendan@mozilla.org has to approve, that's all.
(Assignee)

Comment 7

18 years ago
Patch checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 8

18 years ago
*** Bug 50888 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Developer, please advise how to verify this bug..
QA Contact: lchiang → fenella

Comment 10

17 years ago
Per Esther, assign this to her.
QA Contact: fenella → esther

Comment 11

17 years ago
Reporter can you verify this please. 
QA Contact: esther → stephend
I saw no memory leaks in this area when running Purify on Windows 2000 against a
fresh CVS trunk pull.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.