SeaMonkey email window opens showing all email folders then shrinks to normal

NEW
Unassigned

Status

MailNews Core
Backend
9 years ago
9 months ago

People

(Reporter: Ed_P, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.22) Gecko/20090605 SeaMonkey/1.1.17

When opening the Mail & Newsgroup window from a browser window it initially fills the window with all the default account's email folders then after a second the bar separating the email summary from actual emails moves up to my normal position.

This existed in 1.1.16 and now 1.1.17 also. 

Reproducible: Always

Steps to Reproduce:
1. Browser open
2. Open Mail & Newsgroup 
3. Wait 1 second
Actual Results:  
The window initially fills with all the default account's email folders then after a second the bar separating the email summary from actual emails moves up to my normal position.

Expected Results:  
The Mail & Newsgroup window, under Netscape, would open with the bar separating the email summary from the actual email contents in the position I have set it to.  It should do the same under SeaMonkey.

I have a large number of email folders and subfolders.

Hopefully these images help to clarify the problem I am seeing.

http://img199.imageshack.us/img199/323/seamonkeymail1.jpg

http://img12.imageshack.us/img12/1203/seamonkeymail2.jpg
Can you reproduce with SeaMonkey v2.0a3 / current v2.0b1pre?
Version: unspecified → SeaMonkey 1.1 Branch
(Reporter)

Comment 2

9 years ago
I have not experimented with SeaMonkey 2.x.  I've only recently gotten to SeaMonkey 1.x from Netscape 7.2.

Comment 3

6 years ago
Is this still reproducible?

Updated

6 years ago
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM]
(Reporter)

Comment 4

6 years ago
(In reply to Phoenix from comment #3)
> Is this still reproducible?

Yes, with SeaMonkey 2.4.1.

Comment 5

6 years ago
(In reply to Ed_P from comment #4)
> (In reply to Phoenix from comment #3)
> > Is this still reproducible?
> 
> Yes, with SeaMonkey 2.4.1.

Can you try with latest nightly build - http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-trunk/ ? Backup your current profile to be sure that nothing will be broken by some occasion.
(Reporter)

Comment 6

6 years ago
Which file should I download?  seamonkey-2.7a1.en-US.win32.installer.exe, seamonkey-2.7a1.en-US.win32.tests.zip or seamonkey-2.7a1.en-US.win32.zip

Shouldn't I backup the SeaMonkey Program Files folder also?

Comment 7

6 years ago
Take seamonkey-2.7a1.en-US.win32.zip file, unpack it in separate folder, so main folder in Program Files will be kept untouch, and run unpacked version. It must pick up your current profile without any change in it, so after tests you can turn back on your regular build without any problems. Backuping your current profile is just precaution in case that something go wrong
(Reporter)

Comment 8

6 years ago
Thanks [b]Phoenix[/b].

Problem still occurs.

Comment 9

6 years ago
Okay, there is one test left, try latest Thunderbird nightly - http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/thunderbird-10.0a1.en-US.win32.zip to see, is this problem Seamonkey specific, or comes from shared code
(Reporter)

Comment 10

6 years ago
I see similar problem with Thunderbird.  So much for my idea of converting. :-)
(Reporter)

Comment 11

6 years ago
BTW & FWIW My current SeaMonkey 2.4.1 is on Windows 7 rather than XP and on a faster processor and better graphics card than when the problem was 1st reported.

And I have no idea what the Whiteboard's [Halloween2011Bug][CLOSEME 2012-01-01 WFM]means.
Whiteboard simply marks this bug as touched during the bug triage event nick named Halloween 2011 and also reminds to follow up on these bugs after a while (if nothing happens to them meanwhile). :)

This does seem to be somekind of UI performance problem due to loading a lot of folders but since it also affects TB, it's probably in shared code as Phoenix suggested. Moving.
Status: UNCONFIRMED → NEW
Component: MailNews: General → Backend
Ever confirmed: true
Product: SeaMonkey → MailNews Core
QA Contact: mail → backend
Version: SeaMonkey 1.1 Branch → Trunk

Updated

6 years ago
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM] → [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.