Bug.get_history should be called Bug.history

RESOLVED FIXED in Bugzilla 3.4

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: mkanat, Assigned: mkanat)

Tracking

3.3.4
Bugzilla 3.4
Bug Flags:
approval +
approval3.4 +
blocking3.4 +

Details

Attachments

(1 attachment)

(Assignee)

Description

9 years ago
We have lots of accessors in the Bug namespace, but none of them start with get_ other than get_history. It should just be "Bug.history".
Flags: blocking3.4+
(Assignee)

Comment 1

9 years ago
Created attachment 387164 [details] [diff] [review]
v1
Assignee: webservice → mkanat
Status: NEW → ASSIGNED
Attachment #387164 - Flags: review?(dkl)

Updated

9 years ago
Attachment #387164 - Flags: review?(dkl) → review+

Comment 2

9 years ago
Comment on attachment 387164 [details] [diff] [review]
v1

Looks good. r=LpSolit
(Assignee)

Comment 3

9 years ago
Thanks! :-)
Flags: approval3.4+
Flags: approval+
(Assignee)

Comment 4

9 years ago
tip:

Checking in Bugzilla/WebService/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/WebService/Bug.pm,v  <--  Bug.pm
new revision: 1.38; previous revision: 1.37
done

3.4:

Checking in Bugzilla/WebService/Bug.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/WebService/Bug.pm,v  <--  Bug.pm
new revision: 1.33.2.2; previous revision: 1.33.2.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.