If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

moz-icon:// can not handle fareastern characters URIs in mozilla 1.9.1

RESOLVED DUPLICATE of bug 415761

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 415761
8 years ago
8 years ago

People

(Reporter: Aizawa Tsukasa, Unassigned)

Tracking

({regression})

3.5 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.1) Gecko/20090630 Firefox/3.5 (tete009 SSE2 PGO)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.9.1) Gecko/20090630 Firefox/3.5

if use moz-icon://file:///+URIs contains fareastern characters(chinese, japanese or korean), it does not show the correct icon for the file(exe or any file like '.txt'), but show the folder icon insteaded. 
tested on firefox 3.0.11, its works fine, but its broken in 3.5 release.



Reproducible: Always

Steps to Reproduce:
1.create a folder or file with some fareastern characters in its name. (maybe an localized windows is needed.)
2.open firefox 3.5 and type moz-icon://(path to the file) in the addressbar.

Actual Results:  
it show an folder icon insteaded of the file's icon, and in Firefox 3.0.11, this works correctly.

Expected Results:  
it should show the file's icon.
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
(Reporter)

Comment 1

8 years ago
Created attachment 387205 [details]
english filename uri works fine

english filename uri works fine
(Reporter)

Comment 2

8 years ago
Created attachment 387206 [details]
chinese_filename_uri_shows_folder_icon_insteaded

chinese filename uri shows folder icon insteaded
(Reporter)

Updated

8 years ago
Flags: blocking1.9.1.1?
Probably this bug is dup of Bug 454247, see Bug 454247 comment #6

Updated

8 years ago
Component: Extension Compatibility → General
Keywords: qawanted, regression, regressionwindow-wanted
QA Contact: extension.compatibility → general
(Reporter)

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 415761
Flags: blocking1.9.1.1?
Keywords: qawanted, regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.