Pop-up blocked message displays to short (with javascript referer?)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
9 years ago
7 years ago

People

(Reporter: Dorus Peelen, Unassigned)

Tracking

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-2-25], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nl; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11

The site http://www.dar.nl/ fails to send a pdf, because it require a pop-up to fire. However, after the popup, the page quickly reloads, effectivly hiding the 'pop-up' blocked message. It displays so shortly that it took me some time that the pop-up is the part that fails.

The pop-up from this site has been blocked message should stays there longer, just like the remember password message does.

To reproduce this problem, go trough the following steps:

1. Go to http://www.dar.nl/ (Sorry, dutch site)
2. Click on 'Gemeente Nijmegen' on the left
3. Click on 'Afval & Papierkalenders'
4. Write '6541XK 401' in the white box on the middle of the page.
5. Click on 'Download afvalkalender'

Expected results:
Popup with PDF downloads

Actual Results:
Nothing happens (page quicly refresh with no effect).

Work around:
Add http://www.dar.nl/ to the list of allowed pop-up sites 

Expected Results:
A yellow warning 'bar' on top of my screen that ask if i want to enable pop-ups for this site. And one that stays for more then 1/10 second.

Reproducible: Always

Comment 1

9 years ago
Can you try using Firefox 3.5 and see if you can still reproduce?  Have you tried to reproduce this in Firefox's safe mode?
(Reporter)

Comment 2

9 years ago
I tried this on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090707 Minefield/3.6a1pre with a fresh profile. Also happens there, anything wrong with my STR?
(Reporter)

Comment 3

9 years ago
Oh, and to make it complete, yes, it also happens in 3.5, using a fresh profile and safe mode.

Comment 4

9 years ago
I(In reply to comment #2)
> I tried this on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre)
> Gecko/20090707 Minefield/3.6a1pre with a fresh profile. Also happens there,
> anything wrong with my STR?

ok, thanks.  Nothing wrong with them from what I can tell...I'll have to try when I get home.
Version: unspecified → 3.5 Branch
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-25]
This bug has had the CLOSEME tag for several weeks and the date in the tag is far gone. If the reporter can still see this issue, Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). Then please remove the closeme tag in the whiteboard, mark the bug against the proper version and comment on the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.