Closed Bug 502891 Opened 11 years ago Closed 10 years ago

Bookmarklets with an alert cause the focus to mess up.

Categories

(Firefox :: General, defect, minor)

x86
Linux
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: adrianm2, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090707 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090707 Minefield/3.6a1pre

I was using a bookmarklet by Gervase Markham(see url) and it exposed this bug.  After a bookmarklet does an alert pop up all sorts of strange things happen.  The status bar changes status every time the mouse is moved, the bookmarklet looks like it is being hovered, when it is not.

Reproducible: Always

Steps to Reproduce:
a.Start with a new profile. (optional)
1.Place a bookmarklet on the bookmark toolbar with the following location
javascript:(alert(%22weirdfocus%22));
2.Click ok.
3.Wiggle the mouse around, or type in a text field and watch things flash. 
Actual Results:  
The status bar changes status rapidly, and the bookmarklet is highlighted/not highlighted rapidly.

Expected Results:  
Focus should follow the mouse.

Work around is to manual hover the bookmarklet and focus goes back to normal.
Is this a regression from after the focus refactoring patch landed?
This is not a recent regression: I tested a nightly from January 04 2008, and it had this bug.
This occurs in 3.0 as well. Unlikely to be focus related, as toolbarbuttons aren't focusable. More likely some issue with statusbar updating or not triggering a mouseout/exit properly or something.
This now WFM.

The status bar has been removed, and Link URL preview reworked, which are two of the three things that were interacting weirdly.  The bug was fixed by that work; I guess.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.