Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 502913 - A bug marked as duplicate of a duplicate should also display the bug at the end of the duplicate chain
: A bug marked as duplicate of a duplicate should also display the bug at the e...
Status: NEW
Product: Bugzilla
Classification: Server Software
Component: Creating/Changing Bugs (show other bugs)
: unspecified
: All All
: P3 enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: default-qa
Depends on:
  Show dependency treegraph
Reported: 2009-07-07 13:36 PDT by Zack Weinberg (:zwol)
Modified: 2013-07-20 08:35 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---

patch, v1 (1.74 KB, patch)
2012-03-29 09:37 PDT, Frédéric Buclin
glob: review-
Details | Diff | Splinter Review

Description Zack Weinberg (:zwol) 2009-07-07 13:36:50 PDT
If Bug A is resolved as a duplicate of Bug B, and then Bug B is resolved as a duplicate of Bug C, A should appear to be a duplicate of C from then on.  Similarly, if B is already a duplicate of C when someone resolves A as duplicate of B, A should immediately appear to be duplicate of C.

The cc: lists should also forward in this fashion.

Bug 112532 appears related.
Comment 1 Frédéric Buclin 2012-03-29 09:37:03 PDT
Created attachment 610572 [details] [diff] [review]
patch, v1

This patch is about the first part of your request. The 2nd part about the CC list has already been requested in bug 108983.
Comment 2 Byron Jones ‹:glob› 2012-04-16 11:45:51 PDT
this works, but i'm not totally sold on the wording.

what are your thoughts on displaying the ultimate bug as primary, mentioning intermediate bug(s) secondarily.

so when bug A is dupes to bug B, which is then duped to bug C, bug A would display as:

  RESOLVED DUPLICATE of bug C (via bug B)
Comment 3 Byron Jones ‹:glob› 2012-05-28 07:25:46 PDT
Comment on attachment 610572 [details] [diff] [review]
patch, v1

r- for reasons stated in comment 2.
Comment 4 Frédéric Buclin 2012-08-25 02:57:46 PDT
We are going to branch for Bugzilla 4.4 next week and this bug is too invasive or too risky to be accepted for 4.4 at this point. The target milestone is set to 5.0 which is our next major release.

I ask the assignee to reassign the bug to the default assignee if you don't plan to work on this bug in the near future, to make it clearer which bugs should be fixed by someone else on time for 5.0.

Note You need to log in before you can comment on or make changes to this bug.