Last Comment Bug 502915 - Do XULRunner 1.9.1.0 release
: Do XULRunner 1.9.1.0 release
Status: VERIFIED FIXED
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86 All
: P2 normal (vote)
: ---
Assigned To: Nick Thomas [:nthomas]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 13:41 PDT by Nick Thomas [:nthomas]
Modified: 2013-08-12 21:54 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Nick Thomas [:nthomas] 2009-07-07 13:41:15 PDT
Probably going to use the nightly builders with the FIREFOX_3_5_RELEASE revision, then shuffle stuff about.
Comment 1 Nick Thomas [:nthomas] 2009-07-08 02:23:16 PDT
Builds are in http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/1.9.1-candidates/build1/

Please take them for a spin and give a sign-off if they're OK. 

I've used the mozconfig for the nightly builds, eg
http://hg.mozilla.org/build/buildbot-configs/file/tip/mozilla2/win32/mozilla-1.9.1/xulrunner/mozconfig
Substitute linux or macosx for win32 to get the other platforms. No real difference between nightly and release configs for 1.9.0.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2009-07-13 20:35:52 PDT
These looked OK to me and a few people in #xulrunner took them for a spin too.

I think we can push them to release.

Thanks a lot Nick.
Comment 3 Nick Thomas [:nthomas] 2009-07-22 03:31:25 PDT
Sorry for the delay in finishing this up. Bits are pushed to the mirrors and will appear at
 http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.9.1/

Dave/Mark, could you update the wiki and so on, then resolve this fixed ? Bug 505701 for 1.9.1.1.

---------------------------------------------
RelEng notes: Basically did 
  https://wiki.mozilla.org/Releases/Firefox_3.0.11/BuildNotes#Release_matching_XULRunner_build
with 
 VERSION=1.9.1
 FX_VERSION=3.5
 BUILD=1
and an additional
 cp /home/ftp/pub/firefox/releases/${FX_VERSION}/source/firefox-${FX_VERSION}.bundle \
  source/xulrunner-${VERSION}.bundle
Also used KEY from 3.0.12 rather 3.5 because the GPG key got renewed recently.
Comment 4 Dave Townsend [:mossop] 2009-07-22 04:30:42 PDT
Thanks Nick.

I've updated https://developer.mozilla.org/en/Gecko_SDK and created https://developer.mozilla.org/en/XULRunner_1.9.1_Release_Notes (copied from the 1.9.0 release notes).

Mark can you check over those to see I haven't made any mistakes then verify this.
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2009-07-22 12:21:02 PDT
MDC pages look good

Note You need to log in before you can comment on or make changes to this bug.