Have release-automation (Fx3.0/1.9.0) send notifications to release@m.c

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: joduinn, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [automation])

Attachments

(2 attachments)

The release-automation for FF3.0.x sends status emails (step completion, etc) to build@m.o. However, we are all on release@m.c, so emails should go there instead.

Please change automation to use release@m.c, in preparation for moving any remaining community folks on build@m.o over to community-build@m.o.

Updated

9 years ago
Assignee: nobody → armenzg
Status: NEW → ASSIGNED

Comment 1

9 years ago
Created attachment 389718 [details] [diff] [review]
send emails to release@m.c for 1.9.0 releases

Here is the list of files where build@m.o is being used in case we want to make more changes:
./buildbot-configs/automation/staging/master.cfg
./buildbot-configs/automation/staging/tb-master.cfg
./release/configs/fx-moz18-bootstrap.cfg
./release/configs/fx-moz180-bootstrap.cfg
./release/configs/fx-moz19-bootstrap.cfg
./release/configs/tb-moz18-bootstrap.cfg
./release/configs/tb-moz180-bootstrap.cfg
./release/configs/xr-moz19-bootstrap.cfg
./tinderbox-configs/firefox/linux/tinder-config.pl
./tinderbox-configs/firefox/macosx/tinder-config.pl
./tinderbox-configs/firefox/win32/tinder-config.pl
./tinderbox-configs/seamonkey/linux/tinder-config.pl
./tinderbox-configs/sunbird/macosx/tinder-config.pl
./tinderbox-configs/thunderbird/macosx/tinder-config.pl
./tinderbox-configs/xulrunner/win32/tinder-config.pl
Attachment #389718 - Flags: review?(joduinn)
Don't forget to check the release and l10n_release branches for all of those tinder-config.pl files - they're the ones that are used for Firefox 3.0.x releases.

Comment 3

9 years ago
I checked the branches l10n, release and release_l10n and the email is only being used for thunderbird and xulrunner
(Assignee)

Comment 4

9 years ago
From what I can tell from the tinderbox code, $BuildAdministrator only appears in logs and doesn't cause any actual mail. So I wouldn't be worried about modifying all the tinderbox configs. (There are many more instances than you found, because in some places we use "build\@mozilla.org"). We could ignore the old bootstrap configs too, and just change
  release/configs/tb-moz18-bootstrap.cfg
  release/configs/fx-moz19-bootstrap.cfg
  release/configs/xr-moz19-bootstrap.cfg
Attachment #389718 - Flags: review?(joduinn) → review+

Updated

9 years ago
Priority: -- → P2

Updated

9 years ago
Priority: P2 → P3

Comment 5

9 years ago
Putting it into the queue since I won't be touching it anytime before 2 weeks.
Assignee: armenzg → nobody
Component: Release Engineering → Release Engineering: Future
Priority: P3 → --
Whiteboard: [automation]

Updated

9 years ago
Summary: Have release-automation send notifications to release@m.c → Have release-automation (Fx3.0/1.9.0) send notifications to release@m.c
Whiteboard: [automation]

Updated

9 years ago
Duplicate of this bug: 510022
(Assignee)

Updated

9 years ago
Component: Release Engineering: Future → Release Engineering
(Assignee)

Comment 7

9 years ago
Created attachment 421689 [details] [diff] [review]
Update all bootstrap configs

I'll take a look at the blat config for the windows boxes too.
Assignee: nobody → nrthomas
Attachment #421689 - Flags: review?(bhearsum)
(Assignee)

Updated

9 years ago
Whiteboard: [automation]
(Assignee)

Comment 8

9 years ago
(In reply to comment #7)
> I'll take a look at the blat config for the windows boxes too.

This is a red herring.
Attachment #421689 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 9

9 years ago
Comment on attachment 421689 [details] [diff] [review]
Update all bootstrap configs

If this gets spammy then main person driving the release can be in 'to' and  set cc to joduinn to keep him in the loop.
Attachment #421689 - Flags: checked-in+
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.