Forget About This Site terminated Downloads in progress

RESOLVED INVALID

Status

()

Toolkit
Forget About Site
--
minor
RESOLVED INVALID
9 years ago
5 years ago

People

(Reporter: Blesson, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

While a download is in progress, Selecting "Forget About This Site" option on the download link terminates the download. A zero byte file is created in the download location with the same file name.

Reproducible: Always

Steps to Reproduce:
1. Start a file download
2. Choose Forget About This Site on the download link
Actual Results:  
Terminates the active download. A zero byte file is created in the download location with the same file name.

Expected Results:  
Active download should continue. Download history may be cleared.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Updated

9 years ago
Component: Bookmarks & History → Private Browsing
QA Contact: bookmarks → private.browsing

Updated

9 years ago
Component: Private Browsing → Places
QA Contact: private.browsing → places

Updated

9 years ago
Component: Places → Private Browsing
QA Contact: places → private.browsing

Comment 1

9 years ago
This is by design.  If we let the download continue, then Firefox will keep remembering about the download site, and you will end up with the unexpected behavior of Firefox remembering something you have explicitly asked it not to.  -> INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

5 years ago
Component: Private Browsing → Forget About Site
Product: Firefox → Toolkit
Version: 3.5 Branch → Trunk
You need to log in before you can comment on or make changes to this bug.