If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox behaves strangely when an alert box is opened from a drag event handler

RESOLVED WORKSFORME

Status

()

Core
Drag and Drop
RESOLVED WORKSFORME
8 years ago
a year ago

People

(Reporter: Brian, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

439 bytes, text/html
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11) Gecko/2009060215 Firefox/3.0.11 (.NET CLR 3.5.30729) AutoPager/0.5.2.2 (http://www.teesoft.info/)

Opening an alert box from a dragstart and a dragover event handler on a link causes firefox to behave strangely.  As soon as the alert box opens, the cursor (in this case, a pointer) stops changing according to the defined rules of both other pages and XUL windows.  The window that the alert box is opened from becomes unresponsive to all actions.  Other windows respond to keyboard input, but not mouse input.  Strangely, the text of the dragged link stays present on top of all windows, not just firefox.

Reproducible: Always

Steps to Reproduce:
1. Define a link
2. Attach a drag-related event, which should open an alert box.

See the attached file for a test case.
Actual Results:  
The specific browser window freezes, others mostly freeze, and the link's text is permanently present on the screen.

Expected Results:  
None of the actual results.
(Reporter)

Comment 1

8 years ago
Created attachment 387401 [details]
Test case
Regression range is: http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1176354660&maxdate=1176358979
so it seems to be caused by Bug 375681.
Blocks: 375681
Status: UNCONFIRMED → NEW
Component: General → Drag and Drop
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → drag-drop
Version: unspecified → Trunk
Isn't this the same as bug 100180, basically?
URL: *
Firefox: 49.0a1, Build ID: 20160602030220
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested this issue on the latest Firefox (46.0.1) release and latest Nightly (49.0a1) build. On the Firefox release and Nightly build with e10s disabled, the issue is partially reproducible. When the "Drag Me" link from the provided test case is dragged, the link's text is stuck on the screen even if the browser is minimized. 
However with the latest Nightly build with e10s enabled (it`s default state) the issue is no longer reproducible.

It seems that the window freeze issue is no longer reproducible and it may be fixed by bug 100180. Mike, should I file a different bug for the text link being stuck on the screen when dragging?
Flags: needinfo?(mconley)
(In reply to Cosmin Muntean [:CosminMCG] from comment #4)
> It seems that the window freeze issue is no longer reproducible and it may
> be fixed by bug 100180. Mike, should I file a different bug for the text
> link being stuck on the screen when dragging?

Yes, that sounds like a reasonable thing to do.
Flags: needinfo?(mconley)
See Also: → bug 1280031
Closing this issue as Resolved - WFM due to the fact that the window freeze issue is no longer reproducible. For the other issue with the link's text remained stuck on the screen I have logged bug 1280031.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.