Closed Bug 503081 Opened 12 years ago Closed 12 years ago

fix buildbot exception on reconfig

Categories

(Release Engineering :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 493740

People

(Reporter: bhearsum, Unassigned)

Details

We've had the following exception as part of reconfigs for a long time now:
      File "/tools/buildbot/lib/python2.5/site-packages/buildbot/master.py",
line 759, in <lambda>
        d.addCallback(lambda res: self.loadConfig_Schedulers(schedulers))
      File "/tools/buildbot/lib/python2.5/site-packages/buildbot/master.py",
line 835, in loadConfig_Schedulers
        d.addCallback(updateDownstreams)
      File
"/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py",
line 191, in addCallback
        callbackKeywords=kw)
      File
"/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py",
line 182, in addCallbacks
        self._runCallbacks()
    --- <exception caught here> ---
      File
"/tools/twisted-2.4.0/lib/python2.5/site-packages/twisted/internet/defer.py",
line 307, in _runCallbacks
        self.result = callback(self.result, *args, **kw)
      File "/tools/buildbot/lib/python2.5/site-packages/buildbot/master.py",
line 834, in updateDownstreams
        s.checkUpstreamScheduler()
      File "/tools/buildbot/lib/python2.5/site-packages/buildbot/scheduler.py",
line 350, in checkUpstreamScheduler
        for s in self.parent.allSchedulers():
    <type 'exceptions.AttributeError'>: 'NoneType' object has no attribute
'allSchedulers'


It seemed to be innocuous at first, but as it turns out, it prevents new ChangeSources to be added. There's an upstream patch for this that catlee is pulling in. We'll land it in tomorrow's downtime.
d'oh
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493740
No longer blocks: 459269
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.