Yahoo classic puts up "Loading..." note, blocks FOX from other activity

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: john ruskin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-1], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1) Gecko/20090624 Firefox/3.5 (.NET CLR 3.5.30729)

Whenever Yahoo mail classic is engaged in some activity , it puts up a small message box at the top which reads "Loading . . ." [The periods display in a loop as "." ".." and "..."]

This message box appears when moving to or between mail categories, or when selecting a particular message for downloading.

In and of itself, this is no big deal, but while that box is displaying, all other FOX activity is shutdown or blocked.  This includes or appears to include: page rendering, manually changing tabs, selecting URLs, opening new tabs, downloading content, etc.  

I can not tell if this due to the scripting within Yahoo JS pages, or if it appears due to some rendering or other issue within Fox itself.  

The time of blocking seems to be somewhat tied to the functional speed of my wireless internet connection.  In functional but 20% reception, for example, the block goes on for 5 seconds.

While this may not be related, I also notice that, sometimes, the loading message appears [with the blocking artifact] and then there is no change in the rendered page, as if, after however many seconds, Yahoo could not deliver the content.  This side behavior also tends to happen worse when I am in slower reception areas for the wireless card.

Reproducible: Always

Steps to Reproduce:
1.   Log on to Yahoo Classic
2.   Move to/between mail categories, or to a particular message . . .
3.   . . . causing the "Loading..." message box, which then . . .
4.   . . . blocks/freezes out other FOX activity
Actual Results:  
Fox is blocked from doing other things while the Yahoo content is sought/downloaded

Expected Results:  
I should be able to move between tabs, select URL's , etc., while Yahoo's content is doing its thing in the background on another tab.

Yahoo's messaging box and waiting for content should not obstruct other FOX activity.

This occurred in FOX 3.0.11 and earlier, and continues to occur with 3.5.

This started up with Yahoo's change to the classic mail interface.  I noticed that there was a few weeks between the time that one of my accounts started this behavior [ie, using the "Loading..." message and etc.] , and when the other account also had this newer interface.

I have Adblocker installed, but this occurs with and without that enabled.
(Reporter)

Comment 1

9 years ago
Notes:
a) The behavior continues into 3.5.1
b) This following error occurs when I check mail, and reproduced, here:
 
Error: uncaught exception: [Exception... "Component returned failure code: 0x805e000a [nsIDOMLocation.replace]"  nsresult: "0x805e000a (<unknown>)"  location: "JS frame :: http://mail.yimg.com/d/combo?/mg/6_0_18/js/yui_utils.js&/mg/6_0_18/js/core.js&bc/bc_2.0.4.js&/mg/6_0_18/js/darla.js&/mg/6_0_18/js/async.js&/ult/ylc_1.9.js&/mg/6_0_18/js/imboot.js& :: anonymous :: line 10"  data: no]

c) The typical delay, now, with a full speed wireless modem, is six seconds, the delay is longer with reduced transmission speeds [lower 'bars']
Reporter, are you still seeing this issue with Firefox 3.6.12 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Also, please consider using the most recent Firefox 4 beta build, your bug may be resolved there.
Whiteboard: [CLOSEME 2011-1-1]
(Reporter)

Comment 3

8 years ago
Tyler:  The freeze/delay, brought on by the Yahoo "loading", no longer occurs.   It is as if each tab's processing is in its own space now, reminiscent of changes that got made, and bubbled throughout the code which isolated tabs into seperate processes?

It's either that, or Yahoo made a change in the code they present...

With current version, I can now move between tabs, while one is 'Yahoo Loading'
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.