Closed Bug 503121 Opened 11 years ago Closed 11 years ago

our version of python for windows mobile handles the command line different than the desktop version

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Windows Mobile 6 Professional
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: jmaher, Unassigned)

Details

This issue is related to spaces in the commandline string and the fact that we are expecting two arguments (app, args) vs a single commandline argument.

I found this while doing xpcshell tests on windows mobile where we set constants on the command line like this:
xpcshell -e 'const _HEAD_FILES = ["<path>/head.js", "<path>/head2.js"];'


in order to get this to work, I need to do this:
xpcshell -e 'var[_HEAD_FILES]=[["<path>/head.js","<path>/head2.js"]];'

I suspect the problem is in subprocess.py for the popen handler when it handles 1 commandline vs app/args.  We might be able to do more logical parsing of the command line to split these, or rework the createprocess to just one a single command line.
pushed http://hg.mozilla.org/users/blassey_mozilla.com/pythonce/rev/3e13329ed067

this fixes the problem for all my test cases, if you have any other trouble reopen this bug.

binary: http://people.mozilla.org/~blassey/python25.zip
debug: http://people.mozilla.org/~blassey/python25-d.zip
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
I have the latest python25.zip and it is missing the pipelib.dll and pipedev.dll.  Are these integrated in to another .dll?
It's staticly linked into python25.dll now
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.