If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After resuming from Vista sleep - attempt to visit web site hangs. => 'not responding..'

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: dal765@onetel.com, Unassigned)

Tracking

({hang, perf})

3.0 Branch
x86
Windows Vista
hang, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; FDM; InfoPath.1; BCD2000; .NET CLR 3.5.30729; .NET CLR 3.0.30618; .NET CLR 1.0.3705; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; .NET CLR 1.1.4322; MAXTHON 2.0)
Build Identifier: 3.011

Resume from Vista sleep =>
a. failure to access web site
b. FF is already running but not responding after FF closed and launched.

Reproducible: Always

Steps to Reproduce:
1. FF is working.
2. Sleep.
3. Resume from sleep.
4. Try to open a web site with FF
5. Never completes.
6. Close FF
7. Relaunch => 'FF is already running but not responding...'
8. Cannot close FF process with task manager - needs restart.



FF should not have been affected by Vista sleep.

Maxthon and IE aren't.
Do you need a computer restart or browser restart?
(Reporter)

Comment 2

8 years ago
As is expected following the FF message
'FF is already running but not responding...'
and as I said I can't close the process using task manager

FF only runs again after a full PC restart.

After quite a few weeks of playing with disabling add-ons, I finally associated this at least primarily with Vista Sleep.

I'm having to give up on FF for now as I keep tripping over this, alas.
Does this happen in Firefox 3.5 or later? Also, please create a new profile, and try to reproduce.
http://support.mozilla.com/kb/Profiles
Severity: critical → major
Keywords: hang
Version: unspecified → 3.0 Branch
Is this bug 424559, bug 426089, bug 476278, or bug 434112?
(Reporter)

Comment 5

8 years ago
Hi, thanks for your interest.
424559:
"is able to establish connections to new/current websites open in
the tabs for about 20 mins."

My experience: after resume from sleep, no website access- FF hangs.

426089, 434112 - could well be the same.
"Firefox hangs; must force-quit to proceed."

This sounds much the same- but what is 'force-quit'?

I can't terminate the FF process, and must reboot.

476278
"If I close Firefox and reopen it, the connection to google establishes
immediately.  If I wait about a minute, "

Similar but- I can't relaunch FF. I get the error message I quoted and need to reboot to use FF again.

I did search before posting, on several keywords, but after some time couldn't find exactly the same.

Sorry, I meant FFv3.0.11. not 3.11.

I guess a work around is always to quit FF before sleep, and disable timed sleep mode. But that's really not at all good.

Comment 6

8 years ago
Can you try to reproduce using Firefox 3.5?  If it still happens, can you try in Firefox's safe mode and if it still happens, with a new profile?
(Reporter)

Comment 7

8 years ago
Confirmed, happens with v3.5 as well.

If/when I have time, may try a new profile.

Meanwhile updating to v3.5 stopped Roboform working (incompatible) on which I depend...  so another reason not to use FF right now.
Please report back with new (unmodified) profile results. if roboform does not work, please contact the developers to ask for an update.
(Reporter)

Comment 9

8 years ago
Using a new profile with FF3.5; 
After resuming from Sleep (FF having been left running)
- accessing a NEW web site fails
- FF cannot be relaunched after closing it
- the process cannot be terminated - may be 60Mb or more.
But:
Now there is no error message.
Once it seemed each attempt to launch FF after the failure launched a further process: another time no further process was launched.

I suggest the other bug reports referring to some sites being accessible after resuming from sleep wiht FF running may actually be referring to pages from cache. I found pages I had already viewed were still accessible. New page access failed.

(Roboform has been updated, fortunately- latest is compatible)

Comment 10

8 years ago
Can anything access the network?
This isn't a case of the network being down, and FF handling poorly for some reason?
(Reporter)

Comment 11

8 years ago
Hi, It looks like 3.5.1 has solved this.. I just rechecked;

With FF running, 1 tab open, entered Sleep mode.
Resumed from Sleep.
Accessed new site (not cached).
Worked.

I noticed this improvement with the new version.

In the previous situation, as I think I commented, when FF failed, I could use another browser instead, whilst a useless uncloseable FF process occupied RAM.

However I still sometimes get the 

'FF is already running but not responding' (mentioned above) with a FF task I can't close.

This is really annoying, as if Google desktop search is running, and FF is my default, then switching default browsers to Maxthon is not recognised by GDS (whilst a switch to IE is). As far as I'm concerned, that means I'll use Maxthon as default. This situation is one that REALLY  puts me off FF now.
Shame really.

So, half way there... thanks.

Comment 12

8 years ago
Same problem for me. I clocked the time it takes for firefox to kick in after it hangs until it is responsive again and it is exactly 90 sec. I suspect it is TCP time out that is the cause. I'm not familiar with the Windows enviroment and TCP so I can't really do any useful there. Is there something I can test that would confirm my suspicion?
Keywords: perf
(Reporter)

Comment 13

8 years ago
Hi, I'm turning to Lunascape (a free triple engine browser) which supports many (but not all) FF addons to its Gecko engine.

I've basically stopped using Firefox because of this issue, so have no current experience of this problem.

So far I've had no problems with Lunascape + gecko engine + sleep /resume from sleep.
=> incomplete per reporter comment
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 15

8 years ago
Hi, this problem appears to have disappeared with either v3.5 or 3.6.

That's good news..
Resolution: INCOMPLETE → FIXED

Comment 16

8 years ago
Fixed is for bugs with known patches. Marking wfm.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.